Bug 104460 - Outline incorrectly repainted in compositing layer with overflow:hidden
Summary: Outline incorrectly repainted in compositing layer with overflow:hidden
Status: RESOLVED DUPLICATE of bug 153299
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 17:41 PST by Simon Fraser (smfr)
Modified: 2016-04-22 22:48 PDT (History)
6 users (show)

See Also:


Attachments
Testcase (2.69 KB, text/html)
2012-12-08 17:41 PST, Simon Fraser (smfr)
no flags Details
Patch (20.55 KB, patch)
2013-06-20 19:27 PDT, Yuki Sekiguchi
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from APPLE-EWS-5 for win-future (796.86 KB, application/zip)
2013-06-21 00:25 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2012-12-08 17:41:37 PST
Created attachment 178388 [details]
Testcase

In the attached test case, hover over the grey boxes; note the blue outline. Now hover over one of the first three red boxes; the outline doesn't correctly paint.

Not a recent regression.
Comment 1 Simon Fraser (smfr) 2012-12-08 17:45:45 PST
We probably get the compositing bounds computation wrong with a combination of overflow:hidden and outline.
Comment 2 Yuki Sekiguchi 2013-06-20 19:27:11 PDT
Created attachment 205139 [details]
Patch
Comment 3 Build Bot 2013-06-21 00:25:08 PDT
Comment on attachment 205139 [details]
Patch

Attachment 205139 [details] did not pass win-ews (win):
Output: http://webkit-queues.appspot.com/results/961005

New failing tests:
fast/media/mq-transform-03.html
fast/forms/search-event-delay.html
fast/media/mq-transform-02.html
platform/win/accessibility/multiple-select-element-role.html
Comment 4 Build Bot 2013-06-21 00:25:09 PDT
Created attachment 205156 [details]
Archive of layout-test-results from APPLE-EWS-5 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: APPLE-EWS-5  Port: win-future  Platform: CYGWIN_NT-6.1-WOW64-1.7.20-0.266-5-3-i686-32bit
Comment 5 zalan 2016-02-01 14:35:19 PST
This test case is fixed with the patch from bug 153299

*** This bug has been marked as a duplicate of bug 153299 ***
Comment 6 Daniel Bates 2016-04-22 22:48:29 PDT
Comment on attachment 205139 [details]
Patch

Clearing review flag so that this patch does not appear in the list of pending reviews.