Bug 104340 - REGRESSION (r133155-r133238): Javascript displayed search results don't update screen
Summary: REGRESSION (r133155-r133238): Javascript displayed search results don't updat...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.8
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2012-12-06 21:53 PST by Kevin M. Dean
Modified: 2012-12-28 20:22 PST (History)
2 users (show)

See Also:


Attachments
Initial Search page (68.01 KB, image/jpeg)
2012-12-06 21:53 PST, Kevin M. Dean
no flags Details
White Screen after clicking Run Report (37.07 KB, image/jpeg)
2012-12-06 21:54 PST, Kevin M. Dean
no flags Details
Result after scrolling or resizing (116.83 KB, image/jpeg)
2012-12-06 21:55 PST, Kevin M. Dean
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2012-12-06 21:53:34 PST
Created attachment 178156 [details]
Initial Search page

I don't have a visible test case yet since the problem exists within my cPanel WHM server administration site.

There's a Mail Delivery Report section where you can search the server's email traffic.

You do the search and the results are loaded into the existing page. If I have the page narrow so that the page width is less than the width of the results table, it renders fine.

If I have my window open wider, the page goes white and the results don't draw until I scroll or resize triggering a screen update.
Comment 1 Kevin M. Dean 2012-12-06 21:54:16 PST
Created attachment 178157 [details]
White Screen after clicking Run Report
Comment 2 Kevin M. Dean 2012-12-06 21:55:08 PST
Created attachment 178158 [details]
Result after scrolling or resizing
Comment 3 Simon Fraser (smfr) 2012-12-06 22:57:23 PST
Is that an iframe that's blank?
Comment 4 Kevin M. Dean 2012-12-07 00:00:08 PST
(In reply to comment #3)
> Is that an iframe that's blank?

No it's a standard frame within a frameset.

Note the only element from within that frame that doesn't disappear is the little icon at the upper right of the frame that is in a fixed positioned div.