Bug 104158 - nrwt: collect all of the information about a run into a new RunDetails class
Summary: nrwt: collect all of the information about a run into a new RunDetails class
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
Depends on: 104072
Blocks: 103824 104165
  Show dependency treegraph
 
Reported: 2012-12-05 13:06 PST by Dirk Pranke
Modified: 2012-12-05 15:27 PST (History)
4 users (show)

See Also:


Attachments
Patch (11.01 KB, patch)
2012-12-05 13:07 PST, Dirk Pranke
ojan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2012-12-05 13:06:04 PST
nrwt: collect all of the information about a run into a new RunDetails class
Comment 1 Dirk Pranke 2012-12-05 13:07:42 PST
Created attachment 177815 [details]
Patch
Comment 2 Ryosuke Niwa 2012-12-05 14:03:20 PST
Comment on attachment 177815 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=177815&action=review

> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:59
> +class RunDetails(object):

I’m not sure if RunDetails is a descriptive name. "run" is an overloaded word and can mean a lot of things.
How about something like ManagerResults or simply LayoutTestResults?
Comment 3 Ojan Vafai 2012-12-05 14:11:08 PST
Comment on attachment 177815 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=177815&action=review

>> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:59
>> +class RunDetails(object):
> 
> I’m not sure if RunDetails is a descriptive name. "run" is an overloaded word and can mean a lot of things.
> How about something like ManagerResults or simply LayoutTestResults?

Those are overloaded too. It's hard to think of a name that doesn't have this problem. This class not used that widely, so I'm not too worried about this.

> Tools/Scripts/webkitpy/layout_tests/run_webkit_tests.py:420
> +        if options.lint_test_files:
> +            return lint(port, options)

Really we should just move this into a different script entirely. LintTestExpectations or whatever.
Comment 4 Dirk Pranke 2012-12-05 14:29:34 PST
(In reply to comment #3)
> (From update of attachment 177815 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=177815&action=review
> 
> >> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:59
> >> +class RunDetails(object):
> > 
> > I’m not sure if RunDetails is a descriptive name. "run" is an overloaded word and can mean a lot of things.
> > How about something like ManagerResults or simply LayoutTestResults?
> 
> Those are overloaded too. It's hard to think of a name that doesn't have this problem. This class not used that widely, so I'm not too worried about this.
> 

I'm going to defer the name-picking until a couple patches from now, when I will rename the ResultSummary class as well, if that's okay ...

> > Tools/Scripts/webkitpy/layout_tests/run_webkit_tests.py:420
> > +        if options.lint_test_files:
> > +            return lint(port, options)
> 
> Really we should just move this into a different script entirely. LintTestExpectations or whatever.

Yeah, I've been tempted to do that for some time. Probably a good idea.
Comment 5 Dirk Pranke 2012-12-05 15:27:15 PST
Committed r136769: <http://trac.webkit.org/changeset/136769>