Bug 104153 - [EFL] fast/media reftests are flaky on EFL WK2 Debug tester
Summary: [EFL] fast/media reftests are flaky on EFL WK2 Debug tester
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jussi Kukkonen (jku)
URL:
Keywords: LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2012-12-05 12:08 PST by Zan Dobersek
Modified: 2017-03-11 10:51 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2012-12-05 12:08:21 PST
Most of the tests in fast/media were transformed into reftests in r136708. Since then, most of those are flaky on the EFL WK2 testing bot.
http://trac.webkit.org/changeset/136726

The tests fail in the first run but pass in the second. I guess there's something in WTR that isn't reset after each test.
Comment 1 Dominik Röttsches (drott) 2012-12-10 08:29:19 PST
Jussi, do you want to take a look?
Comment 2 Jussi Kukkonen (jku) 2012-12-11 01:38:31 PST
Yeah, why not. I'll put it on the list...
Comment 3 Jussi Kukkonen (jku) 2012-12-14 07:16:22 PST
(In reply to comment #0)
> The tests fail in the first run but pass in the second. I guess there's something in WTR that isn't reset after each test.

Can you somehow reproduce this (reliably fail, then relaibly pass)? If not, then I think this is a duplicate of bug 103468. I'll update that one as the description is pretty bad. I've tried to figure that one out but I can't see what goes wrong.


The commit that brought this problem to light (or caused it, who knows) was  http://trac.webkit.org/changeset/135935 : it started to generate the snapshots in ui process in order to be able to cover things the webprocess could not.

I'm guessing that all ref tests are flaky, but some are more flaky than others and apparently the build affects things as well: the media tests are only flaky on Release...
Comment 4 Michael Catanzaro 2017-03-11 10:51:15 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.