Bug 10407 - bad SVG text invalidation issues on mouseover/mouseout
Summary: bad SVG text invalidation issues on mouseover/mouseout
Status: RESOLVED DUPLICATE of bug 11984
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL: http://www.wpsenergy.com/JayNick/defa...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-15 00:40 PDT by Eric Seidel (no email)
Modified: 2007-01-08 16:40 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-08-15 00:40:20 PDT
bad SVG text invalidation issues on mouseover/mouseout

http://www.wpsenergy.com/JayNick/default.asp
Comment 1 Oliver Hunt 2006-08-15 01:49:37 PDT
My local build dies with an assertion failure... possibly related to local changes, but it seems a very odd failure otherwise -- anyone else tested this on a debug build?
Comment 2 David Kilzer (:ddkilzer) 2006-08-15 03:41:00 PDT
(In reply to comment #1)
> My local build dies with an assertion failure... possibly related to local
> changes, but it seems a very odd failure otherwise -- anyone else tested this
> on a debug build?

I'm not seeing an assertion failure on my locally-built debug build of WebKit r15867.  I assume you were just moving the mouse over the SVG text links when you got the assertion?
Comment 3 Oliver Hunt 2006-08-15 03:48:49 PDT
Nope i've borked something entirely -- i can't render at all :(

I do have local changes to text layout though so it's probably my fault :(
Comment 4 Eric Seidel (no email) 2007-01-08 16:40:05 PST
Fixed by bug 11984.

*** This bug has been marked as a duplicate of 11984 ***