Bug 103858 - DFG should trigger rage conversion from double to contiguous if it sees a GetByVal on Double being used in an integer context
Summary: DFG should trigger rage conversion from double to contiguous if it sees a Get...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 22:58 PST by Filip Pizlo
Modified: 2012-12-03 01:22 PST (History)
8 users (show)

See Also:


Attachments
the patch (22.51 KB, patch)
2012-12-02 23:03 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (25.77 KB, patch)
2012-12-02 23:52 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (25.76 KB, patch)
2012-12-02 23:57 PST, Filip Pizlo
barraclough: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2012-12-02 22:58:19 PST
Patch forthcoming.  This should undo some of the regressions from typed double arrays.
Comment 1 Filip Pizlo 2012-12-02 23:03:16 PST
Created attachment 177188 [details]
the patch

Not marking r? yet because I think I have some more tricks up my sleeve.
Comment 2 Filip Pizlo 2012-12-02 23:52:05 PST
Created attachment 177194 [details]
the patch

Made it even better.
Comment 3 WebKit Review Bot 2012-12-02 23:54:35 PST
Attachment 177194 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/JavaScriptCore/dfg/DFGArrayMode.h:198:  The parameter name "flags" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Filip Pizlo 2012-12-02 23:57:54 PST
Created attachment 177195 [details]
the patch

Fix style
Comment 5 Filip Pizlo 2012-12-03 01:22:57 PST
Landed in http://trac.webkit.org/changeset/136372