Bug 103742 - [EFL][AC] The content can be scaled while resizing the view
Summary: [EFL][AC] The content can be scaled while resizing the view
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 103105
  Show dependency treegraph
 
Reported: 2012-11-30 07:11 PST by Joone Hur
Modified: 2017-03-11 10:33 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joone Hur 2012-11-30 07:11:07 PST
When you resize the MiniBrowser window, you could see that the content is scaled up/down.
Comment 1 Joone Hur 2012-12-14 13:50:54 PST
This seems like a feature of mobile browser when a web page has the viewport meta tag because the scale of the content depends on the width of the viewport, but I'm not sure if we could support this for all pages that don't have the viewport meta tag. In the case of N9, it doesn't scale the content that doesn't have the viewport meta tag.
Comment 2 Kenneth Rohde Christiansen 2012-12-17 02:02:42 PST
(In reply to comment #1)
> This seems like a feature of mobile browser when a web page has the viewport meta tag because the scale of the content depends on the width of the viewport, but I'm not sure if we could support this for all pages that don't have the viewport meta tag. In the case of N9, it doesn't scale the content that doesn't have the viewport meta tag.

The problem isn't that it scales it, it is the time it does so.
Comment 3 Joone Hur 2012-12-21 11:51:09 PST
(In reply to comment #2)
> (In reply to comment #1)
> > This seems like a feature of mobile browser when a web page has the viewport meta tag because the scale of the content depends on the width of the viewport, but I'm not sure if we could support this for all pages that don't have the viewport meta tag. In the case of N9, it doesn't scale the content that doesn't have the viewport meta tag.
> 
> The problem isn't that it scales it, it is the time it does so.

Do you mean that it takes a little bit time to paint the scaled web page during resizing the window? In this case, we can see the blurred web page for a moment.

Anyway, it seems wrong that all pages can be fitted to the screen by default independent of viewport meta tag . I think that we should give a way to the browser UI to override it.
Comment 4 Kenneth Rohde Christiansen 2012-12-28 03:30:07 PST
> Anyway, it seems wrong that all pages can be fitted to the screen by default independent of viewport meta tag . I think that we should give a way to the browser UI to override it.

Sure, but that is something separate. Also I believe it should never do fit to view for pages supplying a viewport meta tag. It does so today
Comment 5 Michael Catanzaro 2017-03-11 10:33:31 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.