Bug 103680 - [CSS Regions] Text flickers outside of regions when resizing
Summary: [CSS Regions] Text flickers outside of regions when resizing
Status: RESOLVED DUPLICATE of bug 103993
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andrei Bucur
URL:
Keywords: AdobeTracked
Depends on:
Blocks: 57312
  Show dependency treegraph
 
Reported: 2012-11-29 15:46 PST by Rebecca Hauck
Modified: 2012-12-12 09:09 PST (History)
3 users (show)

See Also:


Attachments
test case to reproduce bug (3.75 KB, text/html)
2012-11-29 15:47 PST, Rebecca Hauck
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rebecca Hauck 2012-11-29 15:46:51 PST
Found in Version 25.0.1335.0 canary

1. Open the attached test file in the browser
2. Resize the window by dragging the bottom right corner (happens more reliably when you resize both horizontally & vertically at the same time, but I've seen it when doing just one direction at once, too)

Result:  The text momentarily flickers outside of the rightmost region while re-wrapping
Comment 1 Rebecca Hauck 2012-11-29 15:47:48 PST
Created attachment 176839 [details]
test case to reproduce bug
Comment 2 Andrei Bucur 2012-12-06 02:26:42 PST
The text overflowing the right region doesn't seem to repro after
http://trac.webkit.org/changeset/136793

However, what looks to be a flicker is the text in the right column "bouncing" vertically by 1/2 pixels when resizing the window. Is this a different bug?
Comment 3 Rebecca Hauck 2012-12-10 13:06:30 PST
I'm no longer seeing it flicker like I did before. I do see the slight bouncing in the right pink region though.  Should that be logged as separate bug?
Comment 4 Andrei Bucur 2012-12-10 13:33:09 PST
(In reply to comment #3)
> I'm no longer seeing it flicker like I did before. I do see the slight bouncing in the right pink region though.  Should that be logged as separate bug?

Yes. This can be either a subpixel layout problem or we don't do margin collapsing right at region breaks.
Comment 5 Andrei Bucur 2012-12-12 09:09:02 PST
(In reply to comment #4)
> (In reply to comment #3)
> > I'm no longer seeing it flicker like I did before. I do see the slight bouncing in the right pink region though.  Should that be logged as separate bug?
> 
> Yes. This can be either a subpixel layout problem or we don't do margin collapsing right at region breaks.

I've submitted a new bug: https://bugs.webkit.org/show_bug.cgi?id=104816

*** This bug has been marked as a duplicate of bug 103993 ***