Bug 10342 - prepare-ChangeLog only shows removed files but not added files when files are moved
Summary: prepare-ChangeLog only shows removed files but not added files when files are...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 12021 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-10 23:37 PDT by David Kilzer (:ddkilzer)
Modified: 2007-05-28 14:04 PDT (History)
4 users (show)

See Also:


Attachments
Patch v1 (9.62 KB, patch)
2007-05-28 05:48 PDT, David Kilzer (:ddkilzer)
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-08-10 23:37:48 PDT
The prepare-ChangeLog script apparently only shows the removed files, not the added files, when "svn move" is used to move source files.

It should be smart enough to note the moved files (with to/from paths) when generating the ChangeLog.
Comment 1 David Kilzer (:ddkilzer) 2006-12-31 05:52:04 PST
*** Bug 12021 has been marked as a duplicate of this bug. ***
Comment 2 David Kilzer (:ddkilzer) 2007-05-28 05:48:06 PDT
Created attachment 14756 [details]
Patch v1

Proposed fix.  See ChangeLog for details.
Comment 3 Darin Adler 2007-05-28 09:59:02 PDT
Comment on attachment 14756 [details]
Patch v1

Looks fine. r=me
Comment 4 David Kilzer (:ddkilzer) 2007-05-28 14:04:12 PDT
$ svn commit WebKitTools/ChangeLog WebKitTools/Scripts/prepare-ChangeLog 
Sending        WebKitTools/ChangeLog
Sending        WebKitTools/Scripts/prepare-ChangeLog
Transmitting file data ..
Committed revision 21850.