Bug 10337 - Cannot alternate background colors in a select for 'rule' effect coloring
Summary: Cannot alternate background colors in a select for 'rule' effect coloring
Status: RESOLVED DUPLICATE of bug 6248
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 419.x
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-10 15:12 PDT by j_mckitrick
Modified: 2006-08-11 14:46 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description j_mckitrick 2006-08-10 15:12:25 PDT
Many apps alternate default background and a shaded or highlight background to help the eye follow items horizontally in a list box.  I cannot get any combination of CSS, divs, spans, and options to change the background color of a list box on an item-by-item basis.
Comment 1 Mark Rowe (bdash) 2006-08-11 14:46:45 PDT
Based on the description this sounds like you want CSS 3's "nth-child" pseudo-selector.  See http://www.w3.org/TR/css3-selectors/#nth-child-pseudo for more information.

*** This bug has been marked as a duplicate of 6248 ***