Bug 103358 - Entering Tab View after a bunch of YouTube pages were opened in background tabs makes all of them start playing simultaneously
Summary: Entering Tab View after a bunch of YouTube pages were opened in background ta...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: mitz
URL:
Keywords: InRadar
Depends on: 103388
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 21:44 PST by mitz
Modified: 2012-11-27 13:54 PST (History)
5 users (show)

See Also:


Attachments
Add WKPageSetMayStartMediaWhenInWindow (10.12 KB, patch)
2012-11-26 21:58 PST, mitz
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2012-11-26 21:44:40 PST
Entering Tab View after a bunch of YouTube pages were opened in background tabs makes all of them start playing simultaneously
Comment 1 mitz 2012-11-26 21:47:33 PST
<rdar://problem/11931191>

To fix this, there needs to be API for preventing the normal behavior of media starting when a view is in a window.
Comment 2 mitz 2012-11-26 21:58:04 PST
Created attachment 176169 [details]
Add WKPageSetMayStartMediaWhenInWindow
Comment 3 mitz 2012-11-26 22:35:41 PST
Committed in <http://trac.webkit.org/r135819>.
Comment 4 Thiago Marcos P. Santos 2012-11-27 02:13:22 PST
This patch caused 276 failures on the EFL bots.

http://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/808
Comment 6 WebKit Review Bot 2012-11-27 03:26:28 PST
Re-opened since this is blocked by bug 103388
Comment 7 Csaba Osztrogonác 2012-11-27 03:34:03 PST
(In reply to comment #6)
> Re-opened since this is blocked by bug 103388

Rollout landed in http://trac.webkit.org/changeset/135844
Comment 8 Csaba Osztrogonác 2012-11-27 03:35:21 PST
CC EFL and Qt guys, maybe you can help debugging the regression caused by this patch.
Comment 9 mitz 2012-11-27 13:52:02 PST
I am going to move the initialization of WebPage::m_mayStartMediaWhenInWindow so that it’s before the call to platformInitialize(), thinking that some platforms may call setIsInWindow() from there.
Comment 10 mitz 2012-11-27 13:54:04 PST
Fixed in <http://trac.webkit.org/r135915>.