Bug 103336 - [CSS Grid Layout] Rename grid-{rows|columns} to grid-definition-{rows|columns}
Summary: [CSS Grid Layout] Rename grid-{rows|columns} to grid-definition-{rows|columns}
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
Keywords: EasyFix
Depends on:
Blocks: 60731
  Show dependency treegraph
Reported: 2012-11-26 17:57 PST by Julien Chaffraix
Modified: 2013-07-08 20:09 PDT (History)
14 users (show)

See Also:

Patch (114.99 KB, patch)
2013-05-01 15:47 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff
Rename instead of alias and fix tests (147.66 KB, patch)
2013-06-21 11:10 PDT, Martin Robinson
tony: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Chaffraix 2012-11-26 17:57:43 PST
The specification changed these names since we implemented them.

It's probably too early to do it as the specification didn't stabilize enough.
Comment 1 Martin Robinson 2013-05-01 15:15:44 PDT
Looks like the latest version of the spec [1] keeps this name, so perhaps it's safe to at least add an alias now.

1. http://www.w3.org/TR/css3-grid-layout/#track-sizing
Comment 2 Martin Robinson 2013-05-01 15:47:20 PDT
Created attachment 200246 [details]
Comment 3 Martin Robinson 2013-05-01 15:49:44 PDT
I've updated grid layout tests to reflect the new naming, but didn't update the ietestcenter tests. I figured it would be better to both keep the imported tests similar and to keep some coverage for the old name. I'm happy to change things around if this isn't the preferred approach.
Comment 4 Sergio Villar Senin 2013-06-19 02:47:03 PDT
(In reply to comment #2)
> Created an attachment (id=200246) [details]
> Patch

Since we're not exposing this by default IMO it's OK just to rename them breaking compatibility with the old names instead of adding aliases.

Also consider changing all the references in the tests to the old names, there are several test descriptions that mention grid-rows and/or grid-columns. As far as I saw this involves changing the expected results of two tests as well

Comment 5 Martin Robinson 2013-06-21 11:10:45 PDT
Created attachment 205201 [details]
Rename instead of alias and fix tests
Comment 6 Martin Robinson 2013-07-04 18:35:19 PDT
Any reviewers willing to take this one?
Comment 7 Tony Chang 2013-07-08 13:50:40 PDT
Comment on attachment 205201 [details]
Rename instead of alias and fix tests

View in context: https://bugs.webkit.org/attachment.cgi?id=205201&action=review

> Source/WebCore/ChangeLog:10
> +        Alias -webkit-grid-{rows|columns} to -webkit-grid-definition-{rows|columns}.
> +        The latest version of the spec has renamed these properties and an alias
> +        preserves backwards compatibility with older CSS.

This still talks about aliasing.

> Source/WebCore/ChangeLog:13
> +        (WebCore::CSSComputedStyleDeclaration::getPropertyCSSValue): Handle the new aliases.

Here too.

> Source/WebCore/ChangeLog:20
> +        * css/CSSPropertyNames.in: Add support for the new aliases.
> +        * css/StyleResolver.cpp:
> +        (WebCore::StyleResolver::applyProperty): Handle the new aliases.

Also here.
Comment 8 Martin Robinson 2013-07-08 20:09:58 PDT
Committed r152479: <http://trac.webkit.org/changeset/152479>