Bug 103265 - INVALID_STATE_ERR error upon calling .addCue() twice for the same cue on the same TextTrack
Summary: INVALID_STATE_ERR error upon calling .addCue() twice for the same cue on the ...
Status: RESOLVED DUPLICATE of bug 103264
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://w3c-test.org/html/tests/submis...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2012-11-26 08:47 PST by Antoine Quint
Modified: 2012-12-04 02:29 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2012-11-26 08:47:41 PST
We fail the second test on the Opera-submitted test at http://w3c-test.org/html/tests/submission/Opera/media/interfaces/TextTrack/addCue.html. The test fails because we add the same cue twice to the same TextTrack using .addCue(). The first time it works, the second time we get an INVALID_STATE_ERR exception thrown. This is a bug on our part.
Comment 1 Antoine Quint 2012-11-27 01:54:30 PST
<rdar://problem/12756209>
Comment 2 Antoine Quint 2012-12-04 02:29:47 PST
Fixing https://bugs.webkit.org/show_bug.cgi?id=103264 fixes this issue too.

*** This bug has been marked as a duplicate of bug 103264 ***