Bug 103087 - box-shadow with inset plus border-radius is causing rendering artifacts
: box-shadow with inset plus border-radius is causing rendering artifacts
Status: RESOLVED INVALID
: WebKit
CSS
: 528+ (Nightly build)
: Macintosh Mac OS X 10.8
: P2 Normal
Assigned To:
: http://stackoverflow.com/questions/13...
: InRadar
:
:
  Show dependency treegraph
 
Reported: 2012-11-22 12:23 PST by
Modified: 2013-01-30 01:12 PST (History)


Attachments
screenshot of the issue (14.02 KB, image/png)
2012-11-22 12:23 PST, cyberplus3@gmail.com
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-11-22 12:23:06 PST
Created an attachment (id=175703) [details]
screenshot of the issue

A DIV with box-shadow with inset plus border-radius is causing artifacts on the right of the rendering shadow.

I'm having some artifacts on Safari 6.0.2 on Mountain Lion on my Macbook Pro, using any other browser everything render as it is supposed to be. But curiously using Safari on my iMac with OSX Lion I can't reproduce the issue.

Stackoverflow thread:
http://stackoverflow.com/questions/13505314/artifacts-on-css-rendering-box-shadow-on-safari-6-0-2-on-mountain-lion

CSS
#test{
    width: 200px;
    height: 200px;

    border-radius: 50%;
    background-color: blue;
    box-shadow: inset -3px 0 0 yellow;
}

reproduction http://jsfiddle.net/T966K/1/

screenshot attached
------- Comment #1 From 2012-11-22 12:32:02 PST -------
I could reproduce the issue on a

MacBook Pro 13-inch, Mid 2012
Graphics Intel HD Graphics 4000 384 MB
Software OS X 10.8.2 (12C60)
Safari Version 6.0.2 (8536.26.17)

I could not reproduce on a 

iMac 21.5-inch, Mid 2011
Graphics AMD Radeon HD 6750M 512 MB
Software Mac OS X Lion 10.7.5 (11G63)
Safari 6.0.2 (7536.26.17)
------- Comment #2 From 2012-11-26 10:36:32 PST -------
<rdar://problem/12750455>
------- Comment #3 From 2013-01-15 04:16:13 PST -------
I have MacBook Pro 15'' with Intel HD 4000 and nVidia GeForce GT 650M.

In Safari:
If i set videocard to Intel HD 4000 - i see this bug.
On nVidia - all ok.

In other browsers (Opera, Firefox, Chrome):

On all video cards - all ok.

OS: Mountain Lion 10.8.2
Safari 6.0.2 (8536.26.17)
------- Comment #4 From 2013-01-30 01:09:21 PST -------
Related question over here: http://apple.stackexchange.com/questions/71065/safari-6-rendering-issues-artifacts-on-mountain-lion

I can reproduce this on a:

MacBook Air 13-inch, Mid 2012
Intel HD Graphics 4000 512 MB
OS X 10.8.2 (12C3006)
Safari 6.0.2 (8536.26.17)
------- Comment #5 From 2013-01-30 01:12:38 PST -------
Since this bug is dependent on OS and/or video hardware, it's not a WebKit bug. Please file it at bugreporter.apple.com instead (though, in this case, Simon's already done that for you).