Bug 103008 - [WK2] Expose Accelerated2dCanvas flag set and get in WebKit2
Summary: [WK2] Expose Accelerated2dCanvas flag set and get in WebKit2
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 103380 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-21 19:04 PST by Kyungjin Kim
Modified: 2012-11-27 17:37 PST (History)
8 users (show)

See Also:


Attachments
Patch (4.53 KB, patch)
2012-11-21 20:07 PST, Kyungjin Kim
no flags Details | Formatted Diff | Diff
patch_2D (2.47 KB, patch)
2012-11-27 02:09 PST, Kyungjin Kim
no flags Details | Formatted Diff | Diff
patch_2D (2.47 KB, patch)
2012-11-27 02:11 PST, Kyungjin Kim
no flags Details | Formatted Diff | Diff
patch_2D_rebase (2.47 KB, patch)
2012-11-27 02:30 PST, Kyungjin Kim
no flags Details | Formatted Diff | Diff
Patch (2.69 KB, patch)
2012-11-27 02:44 PST, Kyungjin Kim
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kyungjin Kim 2012-11-21 19:04:45 PST
Add setting APIs for accelerated 2d canvas in WebKit2
Comment 1 Kyungjin Kim 2012-11-21 20:07:39 PST
Created attachment 175571 [details]
Patch
Comment 2 Gyuyoung Kim 2012-11-26 18:28:45 PST
Comment on attachment 175571 [details]
Patch

LGTM
Comment 3 WebKit Review Bot 2012-11-26 19:05:34 PST
Comment on attachment 175571 [details]
Patch

Clearing flags on attachment: 175571

Committed r135803: <http://trac.webkit.org/changeset/135803>
Comment 4 WebKit Review Bot 2012-11-26 19:05:40 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Kenneth Rohde Christiansen 2012-11-27 01:10:59 PST
Comment on attachment 175571 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=175571&action=review

> Source/WebKit2/ChangeLog:8
> +        Add setting APIs for accelerated 2d canvas in WebKit2.

2D!

> Source/WebKit2/UIProcess/API/C/WKPreferences.cpp:451
> +void WKPreferencesSetAccelerated2dCanvasEnabled(WKPreferencesRef preferencesRef, bool flag)

Please no it is called 2D and not 2d! Please fix asap. Especially in public api
Comment 6 Gyuyoung Kim 2012-11-27 01:53:57 PST
Comment on attachment 175571 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=175571&action=review

>> Source/WebKit2/UIProcess/API/C/WKPreferences.cpp:451
>> +void WKPreferencesSetAccelerated2dCanvasEnabled(WKPreferencesRef preferencesRef, bool flag)
> 
> Please no it is called 2D and not 2d! Please fix asap. Especially in public api

Other ports have used *2d* in WK1's APIs. So, I accepted this. However, I also think 2D is correct in WK2 C API level. Sorry.
Comment 7 Kyungjin Kim 2012-11-27 02:09:08 PST
Created attachment 176205 [details]
patch_2D
Comment 8 Kyungjin Kim 2012-11-27 02:11:50 PST
Created attachment 176206 [details]
patch_2D
Comment 9 Kyungjin Kim 2012-11-27 02:30:07 PST
Created attachment 176211 [details]
patch_2D_rebase
Comment 10 Kyungjin Kim 2012-11-27 02:44:53 PST
Reopening to attach new patch.
Comment 11 Kyungjin Kim 2012-11-27 02:44:58 PST
Created attachment 176215 [details]
Patch
Comment 12 Kyungjin Kim 2012-11-27 02:50:09 PST
*** Bug 103380 has been marked as a duplicate of this bug. ***
Comment 13 WebKit Review Bot 2012-11-27 03:21:22 PST
Comment on attachment 176215 [details]
Patch

Clearing flags on attachment: 176215

Committed r135843: <http://trac.webkit.org/changeset/135843>
Comment 14 WebKit Review Bot 2012-11-27 03:21:27 PST
All reviewed patches have been landed.  Closing bug.
Comment 15 Jesus Sanchez-Palencia 2012-11-27 10:54:05 PST
(In reply to comment #3)
> (From update of attachment 175571 [details])
> Clearing flags on attachment: 175571
> 
> Committed r135803: <http://trac.webkit.org/changeset/135803>

Just out of curiosity, is there an implementation of this somewhere? (not only the preference flag, I mean...)
Comment 16 Kyungjin Kim 2012-11-27 17:37:10 PST
(In reply to comment #15)
> (In reply to comment #3)
> > (From update of attachment 175571 [details] [details])
> > Clearing flags on attachment: 175571
> > 
> > Committed r135803: <http://trac.webkit.org/changeset/135803>
> 
> Just out of curiosity, is there an implementation of this somewhere? (not only the preference flag, I mean...)
it will be uploaded within a few days..