Bug 102825 - [Mutation Observers] addedNodes and removedNodes should be empty NodeLists when type != childList
Summary: [Mutation Observers] addedNodes and removedNodes should be empty NodeLists wh...
Status: RESOLVED DUPLICATE of bug 98921
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 10:48 PST by Rafael Weinstein
Modified: 2012-11-20 10:51 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Weinstein 2012-11-20 10:48:54 PST
This was unspecified behavior which Gecko and WebKit implemented different. The DOM4 editor made the call and the decision is for the Gecko behavior (empty NodeList, as opposed to null):

http://dom.spec.whatwg.org/#mutationrecord
Comment 1 Adam Klein 2012-11-20 10:51:14 PST

*** This bug has been marked as a duplicate of bug 98921 ***