Bug 10263 - SVG seems to repaint way too many times during load (and is thus slow)
Summary: SVG seems to repaint way too many times during load (and is thus slow)
Status: RESOLVED DUPLICATE of bug 11984
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL: http://www.carto.net/papers/svg/sampl...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-05 01:09 PDT by Eric Seidel (no email)
Modified: 2007-01-08 16:39 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-08-05 01:09:06 PDT
SVG seems to repaint way too many times during load (and is thus slow)

Maciej suggests that the xml code might not have the same sort of progressive load repaint throttling that html has.
Comment 1 Maciej Stachowiak 2006-08-05 01:15:53 PDT
If you load this SVG directly:

http://www.carto.net/papers/svg/samples/canvas.svg

It takes about 2200ms uncached, about 70ms cached (using the PLT window).

Partly this is because the server is so slow,  time curl -O http://www.carto.net/papers/svg/samples/canvas.svg reports 1.337s. However, the XML tokenizer also doesn't limit the rate of incremental repaints too, so we could be repainiting on each new data chunk to come in which could be suboptimal.
Comment 2 Eric Seidel (no email) 2007-01-08 16:39:45 PST
Fixed by bug 11984.

*** This bug has been marked as a duplicate of 11984 ***