RESOLVED FIXED 102287
Refactor ViewportArguments to only use CSS units
https://bugs.webkit.org/show_bug.cgi?id=102287
Summary Refactor ViewportArguments to only use CSS units
Kenneth Rohde Christiansen
Reported 2012-11-14 14:40:03 PST
SSIA This might take a few patches, but is needed for our css-device-adapt work.
Attachments
Patch (12.63 KB, patch)
2012-11-14 14:40 PST, Kenneth Rohde Christiansen
noam: review+
Kenneth Rohde Christiansen
Comment 1 2012-11-14 14:40:57 PST
Kenneth Rohde Christiansen
Comment 2 2012-11-14 14:41:42 PST
Comment on attachment 174264 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=174264&action=review > Source/WebCore/dom/ViewportArguments.cpp:72 > + float resultWidth = width; > + float resultHeight = height; > + float resultZoom = initialScale; > + float resultMinZoom = minimumScale; > + float resultMaxZoom = maximumScale; These follow the names used in the css-device-adapt. Other patches should do the renaming.
Noam Rosenthal
Comment 3 2012-11-14 16:31:39 PST
Comment on attachment 174264 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=174264&action=review > Source/WebCore/dom/ViewportArguments.cpp:46 > +static inline float clampLengthValue(float value) how about clampLengthValueToSpecDefinedRange? Or otherwise mention in a comment that the "magic numbers" come from the spec, and put a link to the spec.
Kenneth Rohde Christiansen
Comment 4 2012-11-15 00:25:23 PST
Landed in 134749
Note You need to log in before you can comment on or make changes to this bug.