Bug 102278 - [CSS Regions] Bare <li> elements in named flows display counters outside region boundary
Summary: [CSS Regions] Bare <li> elements in named flows display counters outside regi...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Canvas (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 57312
  Show dependency treegraph
 
Reported: 2012-11-14 13:28 PST by Alan Stearns
Modified: 2012-12-13 07:50 PST (History)
4 users (show)

See Also:


Attachments
Test file (555 bytes, text/html)
2012-11-14 13:29 PST, Alan Stearns
no flags Details
similar behavior, but with background-color styled via bare li selector (251 bytes, text/html)
2012-12-03 23:36 PST, Mihai Balan
no flags Details
test file showing behavior for background-color and flow-into (1.21 KB, text/html)
2012-12-03 23:55 PST, Mihai Balan
no flags Details
Test file showing difference in three bare list item cases (1.09 KB, text/html)
2012-12-04 13:38 PST, Alan Stearns
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Stearns 2012-11-14 13:28:37 PST
If you have added <li> elements to a named flow without adding their <ol> or <ul> wrapper to the named flow, the counters or bullets for the list items is displayed outside the bounds of the region.
Comment 1 Alan Stearns 2012-11-14 13:29:44 PST
Created attachment 174240 [details]
Test file
Comment 2 Mihai Balan 2012-12-03 23:36:14 PST
Created attachment 177425 [details]
similar behavior, but with background-color styled via bare li selector

I'm not really sure this is a bug - see the description of list-style-position over at http://www.w3.org/TR/CSS21/generate.html#propdef-list-style-position and the behavior of background-color with a similar selector (bare li).
Comment 3 Mihai Balan 2012-12-03 23:55:10 PST
Created attachment 177426 [details]
test file showing behavior for background-color and flow-into
Comment 4 Alan Stearns 2012-12-04 13:38:04 PST
Created attachment 177540 [details]
Test file showing difference in three bare list item cases

I still think there's something wrong. Take a look at this file. Why is the middle box different?

My guess is that the bare list items in the first and third boxes get an anonymous unordered list box created inside the content area of their yellow boxes, then the bullets are composed inside that box.

In the middle case, there's an empty list in the normal flow somewhere, so the list items in the named flow do not get an anonymous unordered list box created inside the region. I think they should.
Comment 5 Mihai Balan 2012-12-13 07:50:07 PST
As per additional off-line discussions, this is not a bug, thus closing it as RESOLVED/INVALID.

(The gist of it is this: when "simulating" lists using CSS only e.g. with display: list-item and list-style-type: decimal, the marker boxes are drawn outside of the container box. This behavior is consistent with Firefox & Opera, too)