Bug 102221 - [CSS Regions] Auto-sized regions don't recompute their dimensions on window resize
Summary: [CSS Regions] Auto-sized regions don't recompute their dimensions on window r...
Status: RESOLVED DUPLICATE of bug 102954
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mihnea Ovidenie
URL:
Keywords: AdobeTracked
Depends on:
Blocks: 57312
  Show dependency treegraph
 
Reported: 2012-11-14 06:09 PST by Mihai Balan
Modified: 2012-11-30 06:07 PST (History)
4 users (show)

See Also:


Attachments
HTML file highlighting the problem (1.28 KB, text/html)
2012-11-14 06:10 PST, Mihai Balan
no flags Details
using contenteditable doens't expand region (1.35 KB, text/html)
2012-11-16 09:30 PST, Johannes Wilm
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Balan 2012-11-14 06:09:55 PST
Regions that have auto-sizing don't recompute their size when the window resizes. This leads to content being clipped or overflowing (depending on the combination of region-overflow and overflow). Instead, the regions should resize, always keeping the content visible.
Comment 1 Mihai Balan 2012-11-14 06:10:35 PST
Created attachment 174143 [details]
HTML file highlighting the problem
Comment 2 Johannes Wilm 2012-11-16 09:30:53 PST
Created attachment 174707 [details]
using contenteditable doens't expand region

This is very similar and most probably the same bug is behind it which is why I post it here. But instead of looking at window size changes, this is about changes the contents of the element, which should also make it auto-resize.
Comment 3 Alexandru Chiculita 2012-11-30 06:07:06 PST

*** This bug has been marked as a duplicate of bug 102954 ***