Bug 102208 - runCount in runner.js should be renamed to iterationCount
Summary: runCount in runner.js should be renamed to iterationCount
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
Depends on: 102361
Blocks: 77037
  Show dependency treegraph
Reported: 2012-11-14 03:11 PST by Ryosuke Niwa
Modified: 2012-11-15 02:49 PST (History)
7 users (show)

See Also:

Renames (12.41 KB, patch)
2012-11-14 03:23 PST, Ryosuke Niwa
tony: review+
rniwa: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2012-11-14 03:11:54 PST
runCount in runner.js should be renamed to iterationCount
Comment 1 Ryosuke Niwa 2012-11-14 03:23:35 PST
Created attachment 174121 [details]
Comment 2 Ryosuke Niwa 2012-11-14 11:28:45 PST
Comment on attachment 174121 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=174121&action=review

> PerformanceTests/ChangeLog:14
> +        Unfortunately, we still overload the meaning "runs" in "runs/s" (is "function calls/s")

Oh oops, it should read "the meaning of".
Comment 3 Ryosuke Niwa 2012-11-14 11:35:13 PST
Committed r134637: <http://trac.webkit.org/changeset/134637>
Comment 4 Csaba Osztrogonác 2012-11-15 02:49:48 PST
(In reply to comment #3)
> Committed r134637: <http://trac.webkit.org/changeset/134637>

It made fast/harness/perftests/runs-per-second-iterations.html
and fast/harness/perftests/runs-per-second-log.html fail everywhere.

https://bugs.webkit.org/show_bug.cgi?id=102361 - Could you fix it?