Split NetworkRequest up into a request class and a loading class
Sam and I discussed this today how NetworkRequest is a terrible class to do loading. It's better to have one class represent "all the bits of data needed to start a network load", and "the owner of the network load itself"
Created attachment 173827 [details]
Attachment 173827 [details] did not pass style-queue:
Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1
Source/WebKit2/NetworkProcess/HostRecord.cpp:32: Alphabetical sorting problem. [build/include_order] 
Source/WebKit2/NetworkProcess/NetworkResourceLoadScheduler.cpp:8: Alphabetical sorting problem. [build/include_order] 
Source/WebKit2/Shared/Network/NetworkResourceLoadParameters.h:35: Code inside a namespace should not be indented. [whitespace/indent] 
Total errors found: 3 in 14 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Fixed style errors locally
Comment on attachment 173827 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=173827&action=review
> + This patch splits it into "NetworkResourceLoadParameters" for all request-related data
Can the former keep the NetworkRequest name?
(In reply to comment #4)
> (From update of attachment 173827 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=173827&action=review
> Great idea!
> > Source/WebKit2/ChangeLog:10
> > + This patch splits it into "NetworkResourceLoadParameters" for all request-related data
> Can the former keep the NetworkRequest name?
I started out keeping that name, but the naming started to fall apart as the "request" contained a "request" and it also contained datum not related directly to the request.
I also noticed that - from the perspective of WebCore in the WebProcess - this data represents a "ResourceLoader" that has already been created.
I'm definitely open to discussion and suggestions on this naming, but I'm going to land as-is since any changes are an easy substitution followup.