Bug 102026 - Include child layers in the remote layer tree transaction
Summary: Include child layers in the remote layer tree transaction
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 17:59 PST by Anders Carlsson
Modified: 2012-11-12 18:10 PST (History)
1 user (show)

See Also:


Attachments
Patch (8.64 KB, patch)
2012-11-12 18:03 PST, Anders Carlsson
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2012-11-12 17:59:08 PST
Include child layers in the remote layer tree transaction
Comment 1 Anders Carlsson 2012-11-12 18:03:49 PST
Created attachment 173778 [details]
Patch
Comment 2 WebKit Review Bot 2012-11-12 18:06:20 PST
Attachment 173778 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1
Source/WebKit2/WebProcess/WebPage/mac/RemoteGraphicsLayer.h:51:  The parameter name "layer" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/WebProcess/WebPage/mac/RemoteGraphicsLayer.h:52:  The parameter name "layer" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2012-11-12 18:09:12 PST
Comment on attachment 173778 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=173778&action=review

> Source/WebKit2/Shared/mac/RemoteLayerTreeTransaction.mm:116
> +            layerProperties.children.append(childLayer->layerID());

You could prematurely micro-optimize with uncheckedAppend() here!
Comment 4 Anders Carlsson 2012-11-12 18:10:42 PST
Committed r134336: <http://trac.webkit.org/changeset/134336>