Bug 101876 - REGRESSION(r134144): seems to break win 7 chromium browser test (Requested by hayato on #webkit).
: REGRESSION(r134144): seems to break win 7 chromium browser test (Requested by...
Status: RESOLVED FIXED
: WebKit
New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
: 100550
  Show dependency treegraph
 
Reported: 2012-11-11 18:12 PST by
Modified: 2012-11-15 10:30 PST (History)


Attachments
ROLLOUT of r134144 (21.10 KB, patch)
2012-11-11 18:13 PST, WebKit Review Bot
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-11-11 18:12:33 PST
http://trac.webkit.org/changeset/134144 broke the build:
seems to break win 7 chromium browser test (Requested by hayato on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
------- Comment #1 From 2012-11-11 18:13:27 PST -------
Created an attachment (id=173531) [details]
ROLLOUT of r134144

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
------- Comment #2 From 2012-11-11 18:19:08 PST -------
r134144 seems to break Win7 chromium browser tests.

The following tests started to fail since http://build.chromium.org/p/chromium.webkit/builders/Win7%20%28dbg%29/builds/8232.

- PrerenderClickToPlay
- PrerenderNaClPluginDisabled
- PrerenderNaClPluginEnabled


Build log:

http://build.chromium.org/p/chromium.webkit/builders/Win7%20%28dbg%29/builds/8232/steps/browser_tests/logs/PrerenderNaClPluginDisabled

PrerenderBrowserTest.PrerenderNaClPluginDisabled: 
[3960:884:1110/054331:20249600:INFO:CONSOLE(0)] "Only unpacked extensions and apps installed from the Chrome Web Store can load NaCl modules without enabling Native Client in about:flags.", source:  (0)
[3960:884:1110/054332:20249912:FATAL:webcursor_win.cc(104)] Check failed: false.
Backtrace:
base::PlatformThread::Sleep [0x6DB70FD1+2233748]
base::PlatformThread::Sleep [0x6DA1772E+818417]


Check failed in wecursor_win.cc:104.

http://code.google.com/searchframe#OAMlx_jo-ck/src/webkit/glue/webcursor_win.cc&exact_package=chromium&q=webcursor_win.cc&type=cs&l=104


r134144 seems to be related. Let me rollout that and watch the result.
------- Comment #3 From 2012-11-11 18:27:42 PST -------
(From update of attachment 173531 [details])
Clearing flags on attachment: 173531

Committed r134183: <http://trac.webkit.org/changeset/134183>
------- Comment #4 From 2012-11-11 18:27:46 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #5 From 2012-11-11 20:14:56 PST -------
Really?  I thought that patch just added some tests...
------- Comment #6 From 2012-11-12 11:17:34 PST -------
(In reply to comment #5)
> Really?  I thought that patch just added some tests...

I am pretty sure the problem is with the builder.
------- Comment #7 From 2012-11-15 10:30:27 PST -------
For the record this was indeed my fault (one tiny line added to the product itself to support the tests, and I missed adding braces).  See bug 100550 for details and improvements to make it harder to hit this specific issue in the future.  Sorry for the trouble.