Bug 10187 - REGRESSION: Mangled focus ring
Summary: REGRESSION: Mangled focus ring
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://confluence.atlassian.com/pages...
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-08-01 11:39 PDT by Alexander Kellett
Modified: 2007-02-14 19:33 PST (History)
2 users (show)

See Also:


Attachments
Test case reduction (390 bytes, text/html)
2006-08-05 09:30 PDT, jonathanjohnsson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kellett 2006-08-01 11:39:06 PDT
Go to above page. Tab to the comment form field. Notice the very strange shape of the focus ring.
Comment 1 David Kilzer (:ddkilzer) 2006-08-01 15:02:58 PDT
Similar to Bug 10049 for NativePopUp?
Comment 2 jonathanjohnsson 2006-08-05 09:30:52 PDT
Created attachment 9892 [details]
Test case reduction
Comment 3 David Kilzer (:ddkilzer) 2006-08-05 13:17:38 PDT
(In reply to comment #1)
> Similar to Bug 10049 for NativePopUp?

Not so much.  Regressions are P1.
Comment 4 Stephanie Lewis 2006-11-06 19:46:11 PST
radar 4823054
Comment 5 David Kilzer (:ddkilzer) 2006-12-25 06:46:52 PST
This seems to be fixed in my locally-built debug build of WebKit r18411 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Comment 6 Adele Peterson 2007-01-17 11:39:03 PST
I also can not reproduce in the latest build.
Comment 7 Alexander Kellett 2007-01-17 23:45:43 PST
<style>
input:after {
    content: "yay";
}
</style>

<input type="text"/>
Comment 8 Mark Rowe (bdash) 2007-02-06 23:08:34 PST
With the HTML mentioned in comment 7 I see a focus ring that contains both the text field and the generated content, which is what I would expect.  Firefox doesn't seem to display the generated content, so I can't test its behaviour.  I'm tempted to close this as WFM, but the original report is incredibly unclear as to what the problem is so I can't be sure it's working.
Comment 9 Alexander Kellett 2007-02-07 02:29:59 PST
why would you expect the focus ring of the text field to also wrap around another element?
while technically i'm sure there are reasons why you would want to assert that the after: is part of the element, does the spec really take precendence over common sense here?
its looks just plain strange.
Comment 10 Maciej Stachowiak 2007-02-07 04:42:18 PST
It's arguable that this is correct behavior. Yes, it looks weird, but generated content is inherently kind of weird.
Comment 11 Alexander Kellett 2007-02-07 04:50:07 PST
okay.. disagree entirely but feel free to close.
Comment 12 Mark Rowe (bdash) 2007-02-07 04:52:40 PST
Common sense would suggest that using :after on an input element is pretty bizarre thing to do, and thus I would expect bizarre results.  If the generated content is considered when constructing the outline of the element then the behaviour would be correct, otherwise it is incorrect.  I cannot recall which the spec calls for.
Comment 13 Sam Weinig 2007-02-14 19:27:58 PST
I am closing this as WORKSFORME as the original bug has been fixed.  Alex, if you feel the focus ring with the generated content is wrong, would please file a new bug.
Comment 14 Sam Weinig 2007-02-14 19:33:33 PST
Alex, don't worry about creating a new bug, I opened a new bug (bug 12776) to continue the discussion.