MediaStream API: Make sure that MediaConstraints only has optional and mandatory at the top level
Created attachment 173249 [details] Patch
Comment on attachment 173249 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=173249&action=review > Source/WebCore/Modules/mediastream/MediaConstraintsImpl.cpp:70 > + Vector<String>::iterator it = names.begin(); why don't you put the definition of "it" inside the for ()?
Comment on attachment 173249 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=173249&action=review >> Source/WebCore/Modules/mediastream/MediaConstraintsImpl.cpp:70 >> + Vector<String>::iterator it = names.begin(); > > why don't you put the definition of "it" inside the for ()? It makes it more readable imho, I guess you prefer it all in one line? Will fix.
Created attachment 173640 [details] Patch
Comment on attachment 173640 [details] Patch Looks good, thanks
Comment on attachment 173640 [details] Patch Clearing flags on attachment: 173640 Committed r134245: <http://trac.webkit.org/changeset/134245>
All reviewed patches have been landed. Closing bug.