Bug 10150 - document.createElement() in xhtml documents returns unstyleable object
Summary: document.createElement() in xhtml documents returns unstyleable object
Status: RESOLVED DUPLICATE of bug 8007
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-07-29 01:21 PDT by Mark Hubbart
Modified: 2019-02-06 09:03 PST (History)
2 users (show)

See Also:


Attachments
pass/fail test for this bug (684 bytes, application/xhtml+xml)
2006-07-29 01:36 PDT, Mark Hubbart
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hubbart 2006-07-29 01:21:05 PDT
When creating an element in javascript in an xhtml page (application/html+xml), the element returned has no style attribute, making it impossible to modify the css attributes of the element, even after it has been inserted into the document.
Comment 1 Mark Hubbart 2006-07-29 01:34:10 PDT
(In reply to comment #0)
> When creating an element in javascript in an xhtml page (application/html+xml),

correction: application/xhtml+xml
Comment 2 Mark Hubbart 2006-07-29 01:36:34 PDT
Created attachment 9753 [details]
pass/fail test for this bug
Comment 3 David Kilzer (:ddkilzer) 2006-07-29 03:50:43 PDT
Confirmed.  This is not a regression as the same behavior occurs in production Safari 2.0.4 (419.3) on Mac OS X 10.4.7 (8J135/PowerPC).

Test case works fine on Firefox 1.5.0.4.
Comment 4 Alexey Proskuryakov 2006-10-02 08:07:45 PDT

*** This bug has been marked as a duplicate of 8007 ***
Comment 5 Lucas Forschler 2019-02-06 09:03:51 PST
Mass moving XML DOM bugs to the "DOM" Component.