We use quiet NaNs (QNaNs) a lot, and currently the way we refer to them in the code is std::numeric_limits<double>::quiet_NaN(). This is kind of verbose. Instead, we should be able to just say QNaN for short.
This will become even more beneficial for https://bugs.webkit.org/show_bug.cgi?id=98606, which has to use NaNs a lot more.
Created attachment 172257 [details]
Comment on attachment 172257 [details]
WTF's DateMath.cpp could really use this. Should the #define go in WTF?
(In reply to comment #2)
> (From update of attachment 172257 [details])
> WTF's DateMath.cpp could really use this. Should the #define go in WTF?
I will make that move in a separate patch. I want to make sure that this doesn't break anyone's builds first, due to the risk of namespace pollution (some dependent library on some platforms might already be defining it).
Landed in http://trac.webkit.org/changeset/133493