Bug 100723 - webkitgtk-1.10.1 fails to build for gtk/quartz: duplicate symbols in PluginPackage.o and PluginPackageNone.o
Summary: webkitgtk-1.10.1 fails to build for gtk/quartz: duplicate symbols in PluginPa...
Status: CLOSED DUPLICATE of bug 126821
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.7
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-29 20:37 PDT by Jeremy Huddleston Sequoia
Modified: 2016-01-03 22:52 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Huddleston Sequoia 2012-10-29 20:37:31 PDT
Reported at https://trac.macports.org/ticket/36786

Building webkit-gtk with gtk-2 / quartz fails due to:

duplicate symbol WebCore::PluginPackage::determineQuirks(WTF::String const&)  in:
    ./.libs/libWebCore.a(libWebCore_la-PluginPackage.o)
    ./.libs/libWebCore.a(libWebCore_la-PluginPackageNone.o)
ld: 1 duplicate symbol for architecture x86_64


The full build log is available in the downstream macports ticket.
Comment 1 Bruno Abinader (history only) 2013-05-14 07:49:13 PDT
This is also happening on webkit-efl build:

CMakeFiles/webcore_efl.dir/plugins/PluginPackageNone.cpp.o: In function `WebCore::PluginPackage::determineQuirks(WTF::String const&)':
PluginPackageNone.cpp:(.text._ZN7WebCore13PluginPackage15determineQuirksERKN3WTF6StringE+0x0): multiple definition of `WebCore::PluginPackage::determineQuirks(WTF::String const&)'
CMakeFiles/webcore_efl.dir/plugins/PluginPackage.cpp.o:PluginPackage.cpp:(.text._ZN7WebCore13PluginPackage15determineQuirksERKN3WTF6StringE+0x0): first defined here
Comment 2 Bruno Abinader (history only) 2013-05-14 07:50:59 PDT
Note: I am building webkit-efl in x86_64 environment with --no-netscape-plugin-api feature flag set.
Comment 3 Bruno Abinader (history only) 2013-05-14 07:58:53 PDT
Note #2: Removing the --no-netscape-plugin-api resolved the issue.
Comment 4 Philip Chimento 2014-10-03 00:56:57 PDT
This should be solved by my patch on https://bugs.webkit.org/show_bug.cgi?id=126821.
Comment 5 Jeremy Huddleston Sequoia 2016-01-03 22:52:07 PST

*** This bug has been marked as a duplicate of bug 126821 ***