RESOLVED FIXED 100720
Build WebKit as C++11 on Mac
https://bugs.webkit.org/show_bug.cgi?id=100720
Summary Build WebKit as C++11 on Mac
Anders Carlsson
Reported 2012-10-29 19:09:04 PDT
Build WebKit as C++11 on Mac
Attachments
Patch (36.03 KB, patch)
2012-10-29 19:18 PDT, Anders Carlsson
dbates: review+
Anders Carlsson
Comment 1 2012-10-29 19:18:12 PDT
Daniel Bates
Comment 2 2012-10-29 22:21:06 PDT
Comment on attachment 171359 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=171359&action=review > Source/WTF/ChangeLog:8 > + Additional information of the change such as approach, rationale. Please add per-function descriptions below (OOPS!). Please remove these sentences. > Source/WTF/wtf/text/AtomicString.cpp:270 > + UCharBuffer buffer = { s, static_cast<unsigned>(length) }; Would it make sense to change the static type of length from int to unsigned in this function since, as its name implies, it's a length (so it should be non-negative)? Then we don't need to explicitly cast it to unsigned here. > Source/WebCore/platform/network/cf/FormDataStreamCFNet.cpp:467 > + FormContext formContext = { formData.release(), static_cast<unsigned long long>(length) }; Would it make sense to change the static type of length from long long to unsigned long long in this function since, as its name implies, it's a length (so it should be non-negative)? Then we don't need to explicitly cast it to unsigned long long here. > Tools/ChangeLog:8 > + Additional information of the change such as approach, rationale. Please add per-function descriptions below (OOPS!). Please remove these sentences.
Anders Carlsson
Comment 3 2012-10-30 10:39:28 PDT
(In reply to comment #2) > (From update of attachment 171359 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=171359&action=review > > > Source/WTF/wtf/text/AtomicString.cpp:270 > > + UCharBuffer buffer = { s, static_cast<unsigned>(length) }; > > Would it make sense to change the static type of length from int to unsigned in this function since, as its name implies, it's a length (so it should be non-negative)? Then we don't need to explicitly cast it to unsigned here. Yes, it makes sense to do so. > > > Source/WebCore/platform/network/cf/FormDataStreamCFNet.cpp:467 > > + FormContext formContext = { formData.release(), static_cast<unsigned long long>(length) }; > > Would it make sense to change the static type of length from long long to unsigned long long in this function since, as its name implies, it's a length (so it should be non-negative)? Then we don't need to explicitly cast it to unsigned long long here. Ditto. Thanks for reviewing!
Anders Carlsson
Comment 4 2012-10-30 11:07:27 PDT
Note You need to log in before you can comment on or make changes to this bug.