Bug 100407 - WebKit build fails on Windows 7
Summary: WebKit build fails on Windows 7
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-25 13:07 PDT by wazzielookie
Modified: 2012-12-08 16:07 PST (History)
2 users (show)

See Also:


Attachments
BuildLog.htm for WebCore (446.25 KB, text/html)
2012-10-25 13:08 PDT, wazzielookie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description wazzielookie 2012-10-25 13:07:12 PDT
I have selected WebCore JavaScript as the component because it seems that WebKit is failing to build due to some compilation errors within WebCore.  My apologies if this has been mislabeled.

Ask you can guess from the summary title, I am attempting to build WebKit on Windows 7.  I have both the most recent version of WebKit (rev# 132513 at the time of this writing) via the subversion repository and the nightly build source code, and both are failing to build.  The first build errors actually occurred within JavaScriptCore.  Keywords.table had an extra LF at the end of the file which seemed to be confusing the parser.  After removing the additional LF, JavaScriptCore appears to have built correctly, but there seem to be numerous errors when attempting to build WebCore.

I assume WebCore because the "buildfailed" file says the failing project was XXWebCoreXX.  The cygwin/home/<user>/WebKit/WebKitBuild/Release/obj/WebCore/BuildLog.htm has been attached.

Note that some of these are redundant due to dependencies on the same files.
Comment 1 wazzielookie 2012-10-25 13:08:12 PDT
Created attachment 170716 [details]
BuildLog.htm for WebCore
Comment 2 Patrick R. Gansterer 2012-12-08 16:07:23 PST
<http://build.webkit.org/builders/Apple%20Win%20Debug%20%28Build%29> and <http://build.webkit.org/builders/Apple%20Win%20Release%20%28Build%29> build without problems with the current trunk. If you have build problems with a revision which builds on the bots, it is usually a problem with the setup of your machine.
The problems with the line endings are usually caused by "wrong" perl version.