Bug 10031 - drop down form is broken (works in Firefox)
Summary: drop down form is broken (works in Firefox)
Status: RESOLVED DUPLICATE of bug 12280
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: https://citydev-portal.edinburgh.gov....
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-07-20 08:26 PDT by tim bates
Modified: 2007-02-08 14:37 PST (History)
1 user (show)

See Also:


Attachments
Test case/reduction (559 bytes, text/html)
2006-08-27 21:48 PDT, Mike Filippone (donkeyentertain)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim bates 2006-07-20 08:26:59 PDT
At the URL above:

1. Select a service (say  Enquiry Certificate Requests)
2. Selet a user type (say general public)
--> A form should be exposed with several more fields to complete

In safari, nothing happens, in Firefox 1.5, the form is drawn.
Comment 1 Alexey Proskuryakov 2006-07-20 12:49:43 PDT
The server just returns an error to me (500 Internal Server Error). Is the server down, or maybe this page should be navigated to, rather than opened directly?
Comment 2 tim bates 2006-07-20 13:43:14 PDT
to open the problematic form page:

1. go to http://citydev-portal.edinburgh.gov.uk/portal/portal.jsp
2. click on "register for free" (lower left hand side of the page

This opens the problem form. You then simply select a useage need (radio button)

I selected "Property Enquiry Certificate Requests"

Then from the drop down select "general public" as a user type

Now you are seeing the bug: in Safari, the form remains blank, in Firefox it is populated with a series of form elements.

Comment 3 Alexey Proskuryakov 2006-07-21 02:50:58 PDT
Confirmed with r15475.
Comment 4 Mike Filippone (donkeyentertain) 2006-08-27 21:48:47 PDT
Created attachment 10264 [details]
Test case/reduction

Made the reduction in r16061.  

Problem seems to be the document.all("userTypeID") throwing an error since the select element only has a name="userTypeID".  When you put id="userTypeID" in the select tag as well, works fine in Webkit.... Firefox doesn't seem to mind the id not being there.
Comment 5 Roland Corrigal 2007-02-08 14:08:13 PST
I can confirm that this works with the latest nightly build of WebKit  r19494 and not the current release of Safari.

So, in all fairness it's been fixed now :-)
Comment 6 Matt Lilek 2007-02-08 14:26:11 PST
The testcase doesn't work for me in r19506.
Comment 7 David Kilzer (:ddkilzer) 2007-02-08 14:36:49 PST
This was fixed by the fix for Bug 12280.

Matt, the test case works for me with a local debug build of WebKit r19507 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Comment 8 David Kilzer (:ddkilzer) 2007-02-08 14:37:26 PST
Reopening to mark as duplicate.
Comment 9 David Kilzer (:ddkilzer) 2007-02-08 14:37:52 PST

*** This bug has been marked as a duplicate of 12280 ***