WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
100042
[chromium] Add textureWidth() and textureHeight() to WebVideoFrame
https://bugs.webkit.org/show_bug.cgi?id=100042
Summary
[chromium] Add textureWidth() and textureHeight() to WebVideoFrame
John Sheu
Reported
2012-10-22 15:42:53 PDT
[chromium] Add textureWidth() and textureHeight() to WebVideoFrame
Attachments
Patch
(1.47 KB, patch)
2012-10-22 15:43 PDT
,
John Sheu
no flags
Details
Formatted Diff
Diff
Patch
(1.64 KB, patch)
2012-10-22 15:57 PDT
,
John Sheu
no flags
Details
Formatted Diff
Diff
Patch
(2.18 KB, patch)
2012-10-24 15:40 PDT
,
John Sheu
no flags
Details
Formatted Diff
Diff
Patch
(1.83 KB, patch)
2012-10-24 17:46 PDT
,
John Sheu
no flags
Details
Formatted Diff
Diff
Patch
(2.04 KB, patch)
2012-10-24 18:15 PDT
,
John Sheu
no flags
Details
Formatted Diff
Diff
Show Obsolete
(4)
View All
Add attachment
proposed patch, testcase, etc.
John Sheu
Comment 1
2012-10-22 15:43:36 PDT
Created
attachment 170005
[details]
Patch
WebKit Review Bot
Comment 2
2012-10-22 15:47:41 PDT
Please wait for approval from
abarth@webkit.org
,
dglazkov@chromium.org
,
fishd@chromium.org
,
jamesr@chromium.org
or
tkent@chromium.org
before submitting, as this patch contains changes to the Chromium public API. See also
https://trac.webkit.org/wiki/ChromiumWebKitAPI
.
John Sheu
Comment 3
2012-10-22 15:50:26 PDT
Just an interface change at the moment. I'd like to remove stride() eventually, but only after I land the Chromium-side changes as wekk,
James Robinson
Comment 4
2012-10-22 15:51:30 PDT
Comment on
attachment 170005
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=170005&action=review
> Source/Platform/ChangeLog:8 > + Additional information of the change such as approach, rationale. Please add per-function descriptions below (OOPS!).
You have to fill something out here. For this, when would textureWidth/textureHight be different from the frame's width/height? Why do we need separate fields?
John Sheu
Comment 5
2012-10-22 15:57:04 PDT
Created
attachment 170009
[details]
Patch
John Sheu
Comment 6
2012-10-22 17:57:58 PDT
Please take a look here.
James Robinson
Comment 7
2012-10-22 20:18:27 PDT
I can't find any equivalent in media/base/video_frame.h. Perhaps there's some context here I'm missing? Is there a crbug or chromium-side code review that goes along with this?
John Sheu
Comment 8
2012-10-22 20:24:13 PDT
The Chromium bug lives at
http://crbug.com/155416
, and the Chromium-side change is WIP on my checkout. I can't actually checkin for Chromium until this interface change lands, so this one's going first. (As the interface change just adds two accessors, it's safe to do first.)
Ami Fischman
Comment 9
2012-10-22 20:30:22 PDT
(In reply to
comment #8
)
> The Chromium bug lives at
http://crbug.com/155416
, and the Chromium-side change is WIP on my checkout. I can't actually checkin for Chromium until this interface change lands, so this one's going first. (As the interface change just adds two accessors, it's safe to do first.)
@sheu: actually, this is
http://crbug.com/140509
:) You taking that over? (that'd be great, since I haven't had time to touch it) (155416 describes a symptom; 140509 describes the root cause and a plan for fixing it)
James Robinson
Comment 10
2012-10-22 20:35:32 PDT
Comment on
attachment 170009
[details]
Patch Thanks for the info. Slavomir (cc'd) is working on moving the dependency from media -> cc down to not need the WebVideoFrame intermediate data structure, so hopefully this won't be needed in WebKit for long. But for now it definitely is.
John Sheu
Comment 11
2012-10-24 15:40:53 PDT
Created
attachment 170491
[details]
Patch
John Sheu
Comment 12
2012-10-24 15:42:49 PDT
Updated patch. I have a question on naming in the interface. To wit: is visibleX/visibleY/visibleWidth/visibleHeight the right name to use for the added interface functions, in WebKit style?
James Robinson
Comment 13
2012-10-24 16:20:02 PDT
(In reply to
comment #12
)
> Updated patch. > > I have a question on naming in the interface. To wit: is visibleX/visibleY/visibleWidth/visibleHeight the right name to use for the added interface functions, in WebKit style?
The naming is correct - accessors should match the variable name they are accessing - but it'd be better to have the whole thing be one accessor that returns type WebRect instead of 4 individual methods.
John Sheu
Comment 14
2012-10-24 17:46:13 PDT
Created
attachment 170523
[details]
Patch
Peter Beverloo (cr-android ews)
Comment 15
2012-10-24 18:07:48 PDT
Comment on
attachment 170523
[details]
Patch
Attachment 170523
[details]
did not pass cr-android-ews (chromium-android): Output:
http://queues.webkit.org/results/14554451
John Sheu
Comment 16
2012-10-24 18:15:32 PDT
Created
attachment 170530
[details]
Patch
James Robinson
Comment 17
2012-10-24 18:19:02 PDT
Comment on
attachment 170530
[details]
Patch Great, R=me
WebKit Review Bot
Comment 18
2012-10-24 23:32:05 PDT
Comment on
attachment 170530
[details]
Patch Clearing flags on attachment: 170530 Committed
r132448
: <
http://trac.webkit.org/changeset/132448
>
WebKit Review Bot
Comment 19
2012-10-24 23:32:09 PDT
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug