Bug 99707

Summary: [CSS Regions] broken feature detection: body.webkitRegionOverset and body.webkitGetRegionFlowRanges shouldn't succeed when disabled at runtime
Product: WebKit Reporter: Mihai Maerean <mmaerean>
Component: JavaScriptCoreAssignee: Mihai Maerean <mmaerean>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, cmarcelo, haraken, macpherson, menard, morrita, ojan.autocc, WebkitBugTracker, webkit.review.bot
Priority: P2 Keywords: AdobeTracked
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 57312    
Attachments:
Description Flags
1st patch none

Description Mihai Maerean 2012-10-18 04:39:05 PDT
Steps to reproduce:
disable experimental WebKit features (in about://flags/).
access document.body.webkitRegionOverset and document.body.webkitGetRegionFlowRanges from JavaScript.

Expected result:
an exception should occur because the function should not exist.

Actual result:
the call is successful.
Comment 1 Mihai Maerean 2012-12-14 16:49:02 PST
Created attachment 179559 [details]
1st patch
Comment 2 WebKit Review Bot 2012-12-16 02:02:13 PST
Comment on attachment 179559 [details]
1st patch

Clearing flags on attachment: 179559

Committed r137835: <http://trac.webkit.org/changeset/137835>
Comment 3 WebKit Review Bot 2012-12-16 02:02:18 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Kentaro Hara 2012-12-16 15:37:04 PST
Sorry for the delayed comment. Looks good to me too.
Comment 5 Darin Adler 2014-04-24 16:45:55 PDT
Moving all JavaScriptGlue bugs to JavaScriptCore. The JavaScriptGlue framework itself is long gone. And most of the more recent bugs put in this component were put there by people who thought this was for some other aspect of “JavaScript glue” and have nothing to do with the actual original reason for the existence of this component, which was an OS-X-only framework named JavaScriptGlue.