Bug 98731

Summary: [GTK] Test /webkit2/WebKitWebView/history-cache asserts in debug bot
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: gns, mrobinson, webkit.review.bot
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Patch mrobinson: review+

Description Carlos Garcia Campos 2012-10-09 02:04:56 PDT
I think the problem is in the test itself that uses the SingleResourceLoadTest to load a multiresource document.
Comment 1 Carlos Garcia Campos 2012-10-09 02:09:06 PDT
Created attachment 167713 [details]
Patch

I'm unable to reproduce the assertion, so I'm not sure the patch will fix it.
Comment 2 Carlos Garcia Campos 2012-10-09 02:10:12 PDT
Btw, the assertion is this one:

  /webkit2/WebKitWebView/history-cache:                                ASSERTION FAILED: m_loadState == LoadStateCommitted

../../Source/WebKit2/UIProcess/WebFrameProxy.cpp(176) : void WebKit::WebFrameProxy::didFinishLoad()
Comment 3 WebKit Review Bot 2012-10-09 02:11:20 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 4 Carlos Garcia Campos 2012-10-10 04:16:18 PDT
Committed r130886: <http://trac.webkit.org/changeset/130886>