Bug 97022

Summary: Revert 128780, 128676, 128645
Product: WebKit Reporter: Bo Liu <boliu>
Component: New BugsAssignee: Bo Liu <boliu>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, darin, japhet, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Improve ChangeLog description
none
Fix mistake in InternalSettings with INPUT_TYPE_TIME_MULTIPLE_FIELDS none

Description Bo Liu 2012-09-18 09:08:56 PDT
Revert 128780, 128676, 128645
Comment 1 Bo Liu 2012-09-18 09:09:57 PDT
Created attachment 164571 [details]
Patch
Comment 2 Darin Adler 2012-09-18 09:13:46 PDT
Unclear change set. Really need more context here. What are those revisions? Who submitted them? What were they trying to accomplish? Have you contacted the original author?
Comment 3 Bo Liu 2012-09-18 09:15:09 PDT
(In reply to comment #2)
> Unclear change set. Really need more context here. What are those revisions? Who submitted them? What were they trying to accomplish? Have you contacted the original author?

I am the author of all 3 patches. Reverting because they cause performance regression in chromium. See crbug.com/150021
Comment 4 Darin Adler 2012-09-18 09:16:12 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Unclear change set. Really need more context here. What are those revisions? Who submitted them? What were they trying to accomplish? Have you contacted the original author?
> 
> I am the author of all 3 patches. Reverting because they cause performance regression in chromium. See crbug.com/150021

Got it. Could you please add some of that context to the change log? Please don’t assume people know you wrote the code. Or assume they will read the Chromium bug database to understand WebKit code changes.
Comment 5 Bo Liu 2012-09-18 09:21:23 PDT
Created attachment 164576 [details]
Improve ChangeLog description
Comment 6 WebKit Review Bot 2012-09-18 09:24:41 PDT
Attachment 164576 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'ChangeLog', u'LayoutTests/ChangeLog', u'La..." exit_code: 1
LayoutTests/ChangeLog:10:  Line contains tab character.  [whitespace/tab] [5]
LayoutTests/ChangeLog:11:  Line contains tab character.  [whitespace/tab] [5]
Source/WebKit2/ChangeLog:10:  Line contains tab character.  [whitespace/tab] [5]
Source/WebKit2/ChangeLog:11:  Line contains tab character.  [whitespace/tab] [5]
Source/WebCore/ChangeLog:10:  Line contains tab character.  [whitespace/tab] [5]
Source/WebCore/ChangeLog:11:  Line contains tab character.  [whitespace/tab] [5]
ChangeLog:10:  Line contains tab character.  [whitespace/tab] [5]
ChangeLog:11:  Line contains tab character.  [whitespace/tab] [5]
Total errors found: 8 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Bo Liu 2012-09-18 09:34:31 PDT
Created attachment 164578 [details]
Fix mistake in InternalSettings with INPUT_TYPE_TIME_MULTIPLE_FIELDS
Comment 8 WebKit Review Bot 2012-09-18 11:17:48 PDT
Comment on attachment 164578 [details]
Fix mistake in InternalSettings with INPUT_TYPE_TIME_MULTIPLE_FIELDS

Clearing flags on attachment: 164578

Committed r128914: <http://trac.webkit.org/changeset/128914>
Comment 9 WebKit Review Bot 2012-09-18 11:17:51 PDT
All reviewed patches have been landed.  Closing bug.