Bug 96685

Summary: Rename forEachCell to forEachLiveCell
Product: WebKit Reporter: Mark Hahnenberg <mhahnenberg>
Component: JavaScriptCoreAssignee: Mark Hahnenberg <mhahnenberg>
Severity: Normal CC: ggaren
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch oliver: review+

Description Mark Hahnenberg 2012-09-13 12:50:07 PDT
forEachCell actually only iterates over live cells. We should rename it to reflect what it actually does. This is also helpful because I want to add a new forEachCell that actually does iterate each and every cell in a MarkedBlock regardless of whether or not it is live.
Comment 1 Mark Hahnenberg 2012-09-13 13:04:07 PDT
Created attachment 163945 [details]
Comment 2 Mark Hahnenberg 2012-09-13 13:08:27 PDT
Committed r128498: <http://trac.webkit.org/changeset/128498>