Bug 96582

Summary: new test fast/canvas/canvas-css-crazy.html fails on Mac
Product: WebKit Reporter: Stephanie Lewis <slewis>
Component: CanvasAssignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, slewis, thorton, webkit-bug-importer, webkit.review.bot, zan
Priority: P2 Keywords: InRadar, MakingBotsRed
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Stephanie Lewis 2012-09-12 17:33:26 PDT
http://trac.webkit.org/changeset/128374 introduced fast/canvas/canvas-css-crazy.html which fails on the Mac. 

http://build.webkit.org/results/Apple%20Lion%20Release%20WK1%20(Tests)/r128381%20(3497)/results.html

--- /Volumes/Data/slave/lion-release-tests-wk1/build/layout-test-results/fast/canvas/canvas-css-crazy-expected.txt
+++ /Volumes/Data/slave/lion-release-tests-wk1/build/layout-test-results/fast/canvas/canvas-css-crazy-actual.txt
@@ -1,2 +1,3 @@
+ALERT: FAIL! ctx wasn't null: undefined
 ALERT: PASS
Comment 1 Radar WebKit Bug Importer 2012-09-12 17:33:43 PDT
<rdar://problem/12289384>
Comment 2 Adam Barth 2012-09-12 18:30:50 PDT
This is just a minor (long-standing) bug in the custom JSC bindings.  /me will fix shortly.
Comment 3 Stephanie Lewis 2012-09-12 18:32:22 PDT
Thanks.  Is there a bug on JSC bindings issue?
Comment 4 Adam Barth 2012-09-12 18:35:17 PDT
> Thanks.  Is there a bug on JSC bindings issue?

Nope!  This is it now.  (I didn't know it existed until you told me that this test fails.)
Comment 5 Adam Barth 2012-09-12 22:36:46 PDT
Created attachment 163778 [details]
Patch
Comment 6 Adam Barth 2012-09-12 23:38:08 PDT
*** Bug 96606 has been marked as a duplicate of this bug. ***
Comment 7 Csaba Osztrogon√°c 2012-09-12 23:55:03 PDT
Comment on attachment 163778 [details]
Patch

rs=me
Comment 8 WebKit Review Bot 2012-09-13 00:15:45 PDT
Comment on attachment 163778 [details]
Patch

Clearing flags on attachment: 163778

Committed r128411: <http://trac.webkit.org/changeset/128411>
Comment 9 WebKit Review Bot 2012-09-13 00:15:48 PDT
All reviewed patches have been landed.  Closing bug.