Bug 95366

Summary: flexitem-stretch-image.html is flaky
Product: WebKit Reporter: Tony Chang <tony>
Component: Tools / TestsAssignee: Tony Chang <tony>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: jberlin, ojan, shezbaig.wk
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 62048    
Attachments:
Description Flags
Patch none

Description Tony Chang 2012-08-29 12:29:42 PDT
I haven't added this test yet, but it's moving a test that's flaky in flexitem.html to this file.  This should help us identify the flakiness and allow us to get some test coverage back while we diagnose.
Comment 1 Tony Chang 2012-08-29 15:50:50 PDT
Created attachment 161340 [details]
Patch
Comment 2 Ojan Vafai 2012-08-30 10:55:31 PDT
Comment on attachment 161340 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=161340&action=review

> LayoutTests/ChangeLog:11
> +

Maybe mention that you made it only check the one element by using the ID and when we fix the bug, we can delete all the other extraneous junk.
Comment 4 Ojan Vafai 2012-08-30 13:31:34 PDT
As expected, this started failing again on the Chromium Mac debug bots after http://trac.webkit.org/changeset/127050.
Comment 5 Tony Chang 2012-08-30 13:37:45 PDT
Comment on attachment 161340 [details]
Patch

Looks like this test started failing on Chromium Mac Debug, so we don't need this change.
Comment 6 Tony Chang 2012-08-30 13:38:24 PDT
I think Jessie is going to remove the test from mac/TestExpectations.  I think I can remove it in a few other places too.
Comment 7 Jessie Berlin 2012-08-30 13:41:13 PDT
(In reply to comment #6)
> I think Jessie is going to remove the test from mac/TestExpectations.  I think I can remove it in a few other places too.

Removed the test from mac/TestExpectations in http://trac.webkit.org/changeset/127184
Comment 8 Tony Chang 2012-08-30 15:03:14 PDT
Removed from efl/TestExpectations in http://trac.webkit.org/changeset/127196.  The test is only flaky on debug chromium builds, but it may just be a race that is triggered by the slower builds/machines.
Comment 9 Tony Chang 2012-10-08 17:00:56 PDT
The fix for the flaky test is in bug 98611.

*** This bug has been marked as a duplicate of bug 98611 ***