Bug 94288

Summary: RenderBox::computeLogicalClientHeight is incorrectly named
Product: WebKit Reporter: Ojan Vafai <ojan>
Component: Layout and RenderingAssignee: Ojan Vafai <ojan>
Severity: Normal CC: eric, esprehn, hyatt, jchaffraix, tony, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Ojan Vafai 2012-08-16 19:08:46 PDT
clientHeight should include padding but exclude scrollbars (and RenderBox::clientHeight does!). RenderBox::computeLogicalClientHeight returns the box-sizing adjusted content height (excluding both padding and scrollbars). It's especially confusing because computeContentLogicalHeightUsing returns the content height not adjusted for box-sizing and including the scrollbar and computeLogicalHeightUsing returns the border-box size (including scrollbar obviously).

Can't think of a better name at the moment, but computeLogicalClientHeight is definitely wrong.
Comment 1 Ojan Vafai 2012-09-12 14:43:43 PDT
Created attachment 163700 [details]
Comment 2 WebKit Review Bot 2012-09-12 15:29:19 PDT
Comment on attachment 163700 [details]

Clearing flags on attachment: 163700

Committed r128371: <http://trac.webkit.org/changeset/128371>
Comment 3 WebKit Review Bot 2012-09-12 15:29:22 PDT
All reviewed patches have been landed.  Closing bug.