Bug 94106

Summary: [Qt] Make sure that we don't prematurely force the first layout during loading.
Product: WebKit Reporter: Jocelyn Turcotte <jturcotte>
Component: New BugsAssignee: Jocelyn Turcotte <jturcotte>
Status: RESOLVED FIXED    
Severity: Normal CC: kenneth, noam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch kenneth: review+, buildbot: commit-queue-

Description Jocelyn Turcotte 2012-08-15 07:14:23 PDT
[Qt] Make sure that we don't prematurely force the first layout during loading.
Comment 1 Jocelyn Turcotte 2012-08-15 07:16:35 PDT
Created attachment 158564 [details]
Patch
Comment 2 Kenneth Rohde Christiansen 2012-08-15 07:17:26 PDT
Comment on attachment 158564 [details]
Patch

Good catch!
Comment 3 Jocelyn Turcotte 2012-08-15 07:20:52 PDT
r+ed in 51 seconds!
I think it's a record :)
Comment 4 Kenneth Rohde Christiansen 2012-08-15 07:28:49 PDT
(In reply to comment #3)
> r+ed in 51 seconds!
> I think it's a record :)

Heh! I opened the bug report before you attached the patch, so I was prepared :-)
Comment 5 Build Bot 2012-08-15 08:54:18 PDT
Comment on attachment 158564 [details]
Patch

Attachment 158564 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13502743
Comment 6 Jocelyn Turcotte 2012-08-16 01:20:28 PDT
(In reply to comment #5)
> (From update of attachment 158564 [details])
> Attachment 158564 [details] did not pass mac-ews (mac):
> Output: http://queues.webkit.org/results/13502743

The bot is probably sick, this error doesn't make sense if the compile step passed and FrameView::forceLayout is getting linked.
Comment 7 Jocelyn Turcotte 2012-08-16 08:30:57 PDT
Committed r125781: <http://trac.webkit.org/changeset/125781>