Bug 93834

Summary: [V8] Move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, japhet, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 85330    
Attachments:
Description Flags
Patch none

Description Kentaro Hara 2012-08-13 05:56:29 PDT
We can move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h.
Comment 1 Kentaro Hara 2012-08-13 05:57:46 PDT
Created attachment 157975 [details]
Patch
Comment 2 Adam Barth 2012-08-13 10:39:15 PDT
Comment on attachment 157975 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=157975&action=review

> Source/WebCore/bindings/v8/V8GCController.cpp:525
> +    if (data->shouldCollectGarbageSoon()) {

Prefer early return.

> Source/WebCore/bindings/v8/V8GCController.cpp:526
> +        const int longIdlePauseInMs = 1000;

longIdlePauseInMs -> longIdlePauseInMS

> Source/WebCore/bindings/v8/V8GCController.h:79
> +        static void hintForGCIfNecessary();

Can we think of a better name for this function?  Perhaps collectGarbageIfNecessary?
Comment 3 Kentaro Hara 2012-08-13 18:32:20 PDT
(In reply to comment #2)
> > Source/WebCore/bindings/v8/V8GCController.cpp:525
> > +    if (data->shouldCollectGarbageSoon()) {
> 
> Prefer early return.
> 
> > Source/WebCore/bindings/v8/V8GCController.cpp:526
> > +        const int longIdlePauseInMs = 1000;
> 
> longIdlePauseInMs -> longIdlePauseInMS
> 
> > Source/WebCore/bindings/v8/V8GCController.h:79
> > +        static void hintForGCIfNecessary();
> 
> Can we think of a better name for this function?  Perhaps collectGarbageIfNecessary?

Done.
Comment 4 Kentaro Hara 2012-08-13 18:32:29 PDT
Committed r125491: <http://trac.webkit.org/changeset/125491>