Bug 92349

Summary: [EFL] Regression(r123604): webintents/web-intents-obj-constructor.html is crashing
Product: WebKit Reporter: Chris Dumez <cdumez>
Component: WebKit EFLAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: gns, gyuyoung.kim, haraken, kenneth, lucas.de.marchi, mikhail.pozdnyakov, morrita, rakuco, tonikitoo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 92072    
Attachments:
Description Flags
Patch none

Description Chris Dumez 2012-07-26 01:28:04 PDT
strdup has been replaced by eina stringsharing in:
http://trac.webkit.org/changeset/123604

Unfortunately, this change causes webintents/web-intents-obj-constructor.html to crash now.
Comment 1 Chris Dumez 2012-07-26 01:32:47 PDT
Looks like DumpRenderTreeChrome::onFrameIntentNew() was not updated accordingly to use einastringshare_del() instead of free(). I'm preparing a fix now.
Comment 2 Chris Dumez 2012-07-26 01:34:26 PDT
*** Bug 92350 has been marked as a duplicate of this bug. ***
Comment 3 Chris Dumez 2012-07-26 01:43:07 PDT
Created attachment 154577 [details]
Patch
Comment 4 Gyuyoung Kim 2012-07-26 01:48:31 PDT
Comment on attachment 154577 [details]
Patch

Looks fine. Thanks.
Comment 5 Kentaro Hara 2012-07-26 01:49:31 PDT
Comment on attachment 154577 [details]
Patch

Looks OK.
Comment 6 WebKit Review Bot 2012-07-26 03:08:02 PDT
Comment on attachment 154577 [details]
Patch

Clearing flags on attachment: 154577

Committed r123723: <http://trac.webkit.org/changeset/123723>
Comment 7 WebKit Review Bot 2012-07-26 03:08:09 PDT
All reviewed patches have been landed.  Closing bug.