Bug 91941

Summary: Rename ENABLE_METER_TAG and ENABLE_PROGRESS_TAG to ENABLE_METER_ELEMENT and ENABLE_PROGRESS_ELEMENT respectively
Product: WebKit Reporter: Kent Tamura <tkent>
Component: New BugsAssignee: Kent Tamura <tkent>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, cmarcelo, eric, gyuyoung.kim, haraken, macpherson, menard, mifenton, morrita, ojan, rakuco, vestbo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 90846    
Attachments:
Description Flags
Patch
none
Patch 2 haraken: review+

Description Kent Tamura 2012-07-22 07:19:34 PDT
for consistency
Comment 1 Kent Tamura 2012-07-22 08:00:04 PDT
Created attachment 153690 [details]
Patch
Comment 2 Early Warning System Bot 2012-07-22 08:21:09 PDT
Comment on attachment 153690 [details]
Patch

Attachment 153690 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/13311857
Comment 3 Kent Tamura 2012-07-22 08:25:08 PDT
Created attachment 153691 [details]
Patch 2

Qt fix
Comment 4 Kentaro Hara 2012-07-22 15:15:52 PDT
Comment on attachment 153691 [details]
Patch 2

View in context: https://bugs.webkit.org/attachment.cgi?id=153691&action=review

> Source/WebCore/html/shadow/MeterShadowElement.h:87
> +#endif
>  #endif

If there are two or more #endif s, we want to put '#endif // METER_ELEMENT' and '#endif // MeterShadowElement_h'.

> Source/WebCore/html/shadow/ProgressShadowElement.h:88
> +#endif
>  #endif

Ditto.

> LayoutTests/fast/dom/wrapper-classes.html:281
> +    // Conditional elements, VIDEO, PROGRESS_ELEMENT, RUBY, DATALIST_ELEMENT, METER_ELEMENT.

Nit: DATALIST => DATALIST_ELEMENT is intended? Looks good though.
Comment 5 Kent Tamura 2012-07-22 16:24:15 PDT
Committed r123300: <http://trac.webkit.org/changeset/123300>
Comment 6 Kent Tamura 2012-07-22 16:26:44 PDT
Comment on attachment 153691 [details]
Patch 2

View in context: https://bugs.webkit.org/attachment.cgi?id=153691&action=review

>> Source/WebCore/html/shadow/MeterShadowElement.h:87
>>  #endif
> 
> If there are two or more #endif s, we want to put '#endif // METER_ELEMENT' and '#endif // MeterShadowElement_h'.

Done.

>> Source/WebCore/html/shadow/ProgressShadowElement.h:88
>>  #endif
> 
> Ditto.

Done.

>> LayoutTests/fast/dom/wrapper-classes.html:281
>> +    // Conditional elements, VIDEO, PROGRESS_ELEMENT, RUBY, DATALIST_ELEMENT, METER_ELEMENT.
> 
> Nit: DATALIST => DATALIST_ELEMENT is intended? Looks good though.

Yes. We shouldn't add unrelated changes basically, however I think it's ok in this case because I'm modifying this line.