Bug 90706

Summary: Reproducible crash in inspector/timeline/timeline-frames.html
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: fpizlo, kadam, ossy, PeterHWang, rniwa, zarvai
Priority: P2 Keywords: LayoutTestFailure
Version: 528+ (Nightly build)   
Hardware: Macintosh   
OS: All   
Bug Depends on:    
Bug Blocks: 79668    
Attachments:
Description Flags
crash log of Qt none

Description Filip Pizlo 2012-07-06 16:00:59 PDT
It looks like an assertion fail at:

0   com.apple.WebCore             	0x000000010fa3bf16 WebCore::InspectorTimelineAgent::didCancelFrame() + 102 (InspectorTimelineAgent.cpp:203)
1   com.apple.WebCore             	0x000000010f9ef640 WebCore::InspectorInstrumentation::didCancelFrameImpl(WebCore::InstrumentingAgents*) + 48 (InspectorInstrumentation.cpp:414)
2   libWebCoreTestSupport.dylib   	0x000000010dbf0d22 WebCore::InspectorInstrumentation::didCancelFrame(WebCore::Page*) + 66 (InspectorInstrumentation.h:779)
3   libWebCoreTestSupport.dylib   	0x000000010dbeef65 WebCore::Internals::emitInspectorDidCancelFrame() + 37 (Internals.cpp:988)
4   libWebCoreTestSupport.dylib   	0x000000010dc01f77 WebCore::jsInternalsPrototypeFunctionEmitInspectorDidCancelFrame(JSC::ExecState*) + 311 (JSInternals.cpp:1421)
5   ???                           	0x00002e013e401265 0 + 50582874231397
6   com.apple.JavaScriptCore      	0x000000010de4cd34 JSC::JITCode::execute(JSC::RegisterFile*, JSC::ExecState*, JSC::JSGlobalData*) + 84 (JITCode.h:133)
7   com.apple.JavaScriptCore      	0x000000010de44a29 JSC::Interpreter::execute(JSC::EvalExecutable*, JSC::ExecState*, JSC::JSValue, JSC::ScopeChainNode*, int) + 2265 (Interpreter.cpp:1607)
8   com.apple.JavaScriptCore      	0x000000010dd3d94b JSC::Interpreter::execute(JSC::EvalExecutable*, JSC::ExecState*, JSC::JSValue, JSC::ScopeChainNode*) + 123 (Interpreter.h:317)
9   com.apple.JavaScriptCore      	0x000000010ded1b8e JSC::globalFuncEval(JSC::ExecState*) + 1182 (JSGlobalObjectFunctions.cpp:525)
10  ???                           	0x00002e013e401265 0 + 50582874231397
11  com.apple.JavaScriptCore      	0x000000010de4cd34 JSC::JITCode::execute(JSC::RegisterFile*, JSC::ExecState*, JSC::JSGlobalData*) + 84 (JITCode.h:133)
12  com.apple.JavaScriptCore      	0x000000010de49abc JSC::Interpreter::executeCall(JSC::ExecState*, JSC::JSObject*, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 1724 (Interpreter.cpp:1303)
13  com.apple.JavaScriptCore      	0x000000010dd03ed8 JSC::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 296 (CallData.cpp:39)
14  com.apple.WebCore             	0x000000010faaa5e2 WebCore::JSMainThreadExecState::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 146 (JSMainThreadExecState.h:56)
15  com.apple.WebCore             	0x0000000110464b28 WebCore::ScriptFunctionCall::call(bool&, bool) + 536 (ScriptFunctionCall.cpp:144)
16  com.apple.WebCore             	0x000000010f913e25 WebCore::InjectedScriptBase::callFunctionWithEvalEnabled(WebCore::ScriptFunctionCall&, bool&) const + 213 (InjectedScriptBase.cpp:91)
17  com.apple.WebCore             	0x000000010f913ef9 WebCore::InjectedScriptBase::makeCall(WebCore::ScriptFunctionCall&, WTF::RefPtr<WebCore::InspectorValue>*) + 137 (InjectedScriptBase.cpp:108)
18  com.apple.WebCore             	0x000000010f91409a WebCore::InjectedScriptBase::makeEvalCall(WTF::String*, WebCore::ScriptFunctionCall&, WTF::RefPtr<WebCore::TypeBuilder::Runtime::RemoteObject>*, WebCore::TypeBuilder::OptOutput<bool>*) + 74 (InjectedScriptBase.cpp:120)
19  com.apple.WebCore             	0x000000010f90fb73 WebCore::InjectedScript::evaluate(WTF::String*, WTF::String const&, WTF::String const&, bool, bool, WTF::RefPtr<WebCore::TypeBuilder::Runtime::RemoteObject>*, WebCore::TypeBuilder::OptOutput<bool>*) + 275 (InjectedScript.cpp:70)
20  com.apple.WebCore             	0x000000010fa24d97 WebCore::InspectorRuntimeAgent::evaluate(WTF::String*, WTF::String const&, WTF::String const*, bool const*, bool const*, int const*, bool const*, WTF::RefPtr<WebCore::TypeBuilder::Runtime::RemoteObject>&, WebCore::TypeBuilder::OptOutput<bool>*) + 551 (InspectorRuntimeAgent.cpp:99)
21  com.apple.WebCore             	0x000000010fa24fc0 non-virtual thunk to WebCore::InspectorRuntimeAgent::evaluate(WTF::String*, WTF::String const&, WTF::String const*, bool const*, bool const*, int const*, bool const*, WTF::RefPtr<WebCore::TypeBuilder::Runtime::RemoteObject>&, WebCore::TypeBuilder::OptOutput<bool>*) + 160
22  com.apple.WebCore             	0x000000010f95b5c7 WebCore::InspectorBackendDispatcherImpl::Runtime_evaluate(long, WebCore::InspectorObject*) + 1367 (InspectorBackendDispatcher.cpp:1183)
23  com.apple.WebCore             	0x000000010f975bf8 WebCore::InspectorBackendDispatcherImpl::dispatch(WTF::String const&) + 1832 (InspectorBackendDispatcher.cpp:5162)
24  com.apple.WebCore             	0x000000010f9859a0 WebCore::InspectorController::dispatchMessageFromFrontend(WTF::String const&) + 96 (InspectorController.cpp:334)
25  com.apple.WebCore             	0x000000010f9eaaff WebCore::InspectorBackendDispatchTask::onTimer(WebCore::Timer<WebCore::InspectorBackendDispatchTask>*) + 111 (InspectorFrontendClientLocal.cpp:92)
26  com.apple.WebCore             	0x000000010f9eaf03 WebCore::Timer<WebCore::InspectorBackendDispatchTask>::fired() + 115 (Timer.h:100)
27  com.apple.WebCore             	0x0000000110777f00 WebCore::ThreadTimers::sharedTimerFiredInternal() + 288 (ThreadTimers.cpp:118)
28  com.apple.WebCore             	0x0000000110777c99 WebCore::ThreadTimers::sharedTimerFired() + 25 (ThreadTimers.cpp:94)
29  com.apple.WebCore             	0x00000001104cbe63 _ZN7WebCoreL10timerFiredEP16__CFRunLoopTimerPv + 67 (SharedTimerMac.mm:167)
30  com.apple.CoreFoundation      	0x00007fff892ecc24 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
31  com.apple.CoreFoundation      	0x00007fff892ec776 __CFRunLoopDoTimer + 534
32  com.apple.CoreFoundation      	0x00007fff892cd001 __CFRunLoopRun + 1617
33  com.apple.CoreFoundation      	0x00007fff892cc676 CFRunLoopRunSpecific + 230
34  com.apple.Foundation          	0x00007fff8ac98f9f -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 267
35  DumpRenderTree                	0x000000010da8e069 _ZL7runTestRKNSt3__112basic_stringIcNS_11char_traitsIcEENS_9allocatorIcEEEE + 5657
36  DumpRenderTree                	0x000000010da8c9aa _ZL20runTestingServerLoopv + 282
37  DumpRenderTree                	0x000000010da8c23a dumpRenderTree(int, char const**) + 394
38  DumpRenderTree                	0x000000010da8e8a9 main + 105
39  DumpRenderTree                	0x000000010da770c4 start + 52
Comment 1 Filip Pizlo 2012-07-06 16:05:12 PDT
Skipped in http://trac.webkit.org/changeset/122038
Comment 2 Kristóf Kosztyó 2012-07-09 00:04:07 PDT
Created attachment 151195 [details]
crash log of Qt

It also crash on Qt.
Comment 3 Ryosuke Niwa 2013-05-22 17:59:08 PDT
No longer crashes.
Comment 4 Csaba Osztrogonác 2013-05-22 23:26:39 PDT
Could you guys check it on Qt? And please unskip if it really passes.
Comment 5 Ryosuke Niwa 2013-05-22 23:34:34 PDT
(In reply to comment #4)
> Could you guys check it on Qt? And please unskip if it really passes.

I've unskipped it on Mac, and I haven't seen it failing so far.
Comment 6 Zoltan Arvai 2013-05-23 01:16:49 PDT
(In reply to comment #4)
> Could you guys check it on Qt? And please unskip if it really passes.

It passes on Qt WK1, but fails with timeout on Qt WK2.
Comment 7 Csaba Osztrogonác 2013-05-23 02:06:50 PDT
(In reply to comment #6)
> (In reply to comment #4)
> > Could you guys check it on Qt? And please unskip if it really passes.
> 
> It passes on Qt WK1, but fails with timeout on Qt WK2.
In this case could you unskip? (FYI: all inspector tests are 
skipped on Qt-WK2 because all of them fail with timeout)
Comment 8 Zoltan Arvai 2013-05-23 02:22:28 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #4)
> > > Could you guys check it on Qt? And please unskip if it really passes.
> > 
> > It passes on Qt WK1, but fails with timeout on Qt WK2.
> In this case could you unskip? (FYI: all inspector tests are 
> skipped on Qt-WK2 because all of them fail with timeout)

Sure! Unskipped on Qt in http://trac.webkit.org/changeset/150577.