Bug 90435

Summary: [CSS Regions] Enabling regions on Windows lead to crash-on-launch for WebKit.exe
Product: WebKit Reporter: Mihai Balan <mibalan>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: jhoneycutt, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Windows 7   
Bug Depends on:    
Bug Blocks: 57312    
Attachments:
Description Flags
Moved getter/setter for css regions in IWebPreferences.idl at the end of the file fixes the crash none

Description Mihai Balan 2012-07-03 00:19:29 PDT
After fixing #88645 WebKit.exe started crashing upon launch.

Upon further investigation the problem was in IWebPreferences.idl, where the setter/getter for css regions was added in the middle of the interface and not at the end. (A similar thing happened here http://trac.webkit.org/changeset/95650 )
Comment 1 Mihai Balan 2012-07-03 00:42:29 PDT
Created attachment 150552 [details]
Moved getter/setter for css regions in IWebPreferences.idl at the end of the file fixes the crash
Comment 2 Csaba Osztrogon√°c 2012-07-03 02:08:45 PDT
Comment on attachment 150552 [details]
Moved getter/setter for css regions in IWebPreferences.idl at the end of the file fixes the crash

rs=me
Comment 3 WebKit Review Bot 2012-07-03 03:25:52 PDT
Comment on attachment 150552 [details]
Moved getter/setter for css regions in IWebPreferences.idl at the end of the file fixes the crash

Clearing flags on attachment: 150552

Committed r121755: <http://trac.webkit.org/changeset/121755>
Comment 4 WebKit Review Bot 2012-07-03 03:25:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Mihai Balan 2012-11-22 00:08:06 PST
*** Bug 89430 has been marked as a duplicate of this bug. ***