Bug 89338

Summary: fast/files/xhr-response-blob should use other file/blob type than javascript
Product: WebKit Reporter: Kinuko Yasuda <kinuko>
Component: WebCore Misc.Assignee: Kinuko Yasuda <kinuko>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, haraken, ossy, rakuco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch haraken: review+

Description Kinuko Yasuda 2012-06-18 02:29:05 PDT
fast/files/xhr-response-blob should use other file/blob type than javascript as different platforms return slightly different MIME types for javascript (e.g. text/javascript, application/javascript, application/x-javascript etc).  Maybe simple text/plain file would be nicer.
Comment 1 Kinuko Yasuda 2012-06-18 03:19:17 PDT
Created attachment 148080 [details]
Patch
Comment 2 Kentaro Hara 2012-06-18 03:42:43 PDT
Comment on attachment 148080 [details]
Patch

Looks great!
Comment 3 Kinuko Yasuda 2012-06-18 04:14:32 PDT
*** Bug 89343 has been marked as a duplicate of this bug. ***
Comment 4 Kinuko Yasuda 2012-06-18 04:17:07 PDT
Committed r120587: <http://trac.webkit.org/changeset/120587>
Comment 5 Csaba Osztrogon√°c 2012-06-18 04:19:25 PDT
(In reply to comment #4)
> Committed r120587: <http://trac.webkit.org/changeset/120587>

Yay, many thanks.