Bug 87155

Summary: REGRESSION (r90971): the cursor is painted “behind” the placeholder text
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Layout and RenderingAssignee: Kent Tamura <tkent>
Status: RESOLVED FIXED    
Severity: Normal CC: dglazkov, morrita, tkent, webkit.review.bot
Priority: P1 Keywords: InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 121058    
Attachments:
Description Flags
test case
none
screenshot
none
Patch none

Description Alexey Proskuryakov 2012-05-22 12:07:05 PDT
Created attachment 143345 [details]
test case

* STEPS TO REPRODUCE
1.  Load the attached simplified test page
2.  Click in the input field and look at the blinking I cursor

The insertion point should be opaque, but it no longer is.
Comment 1 Alexey Proskuryakov 2012-05-22 12:08:45 PDT
Created attachment 143348 [details]
screenshot
Comment 2 Alexey Proskuryakov 2012-05-22 12:09:32 PDT
<rdar://problem/11492516>
Comment 3 Kent Tamura 2012-05-28 00:05:02 PDT
Created attachment 144287 [details]
Patch
Comment 4 Hajime Morrita 2012-05-29 00:42:18 PDT
Comment on attachment 144287 [details]
Patch

Looks reasonable. It's sad to see we need to touch the renderer here though.
Comment 5 Kent Tamura 2012-05-29 00:43:42 PDT
(In reply to comment #4)
> Looks reasonable. It's sad to see we need to touch the renderer here though.

Yeah, I'll revisit this issue in the future when the editing code becomes shadow-clean.
Comment 6 WebKit Review Bot 2012-05-29 01:23:35 PDT
Comment on attachment 144287 [details]
Patch

Clearing flags on attachment: 144287

Committed r118733: <http://trac.webkit.org/changeset/118733>
Comment 7 WebKit Review Bot 2012-05-29 01:23:40 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Ryosuke Niwa 2013-09-09 16:30:23 PDT
Comment on attachment 144287 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=144287&action=review

> Source/WebCore/html/HTMLTextFormControlElement.cpp:172
> +    // FIXME: We should change the order of DOM nodes. But it makes an assertion
> +    // failure in editing code.

That's because the assertion in the editing code is bogus.