Bug 87147

Summary: add back the ability to disable flexbox
Product: WebKit Reporter: Tony Chang <tony>
Component: Layout and RenderingAssignee: Ojan Vafai <ojan>
Status: RESOLVED FIXED    
Severity: Normal CC: dglazkov, eoconnor, macpherson, menard, mjs, ojan, ossy, pnormand, rakuco, simon.fraser, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Archive of layout-test-results from ec2-cq-01
none
Archive of layout-test-results from ec2-cr-linux-02
none
Patch for landing none

Description Tony Chang 2012-05-22 11:04:07 PDT
We need to be able to disable the new flexbox as the spec settles down.

The easiest way is to add an ENABLE flag that disables just the css parsing of display: -webkit-flex.  We should keep it enabled on trunk so we can keep running the tests on the bots.
Comment 1 Ojan Vafai 2012-05-23 13:02:17 PDT
Created attachment 143626 [details]
Patch
Comment 2 Tony Chang 2012-05-23 13:30:43 PDT
Comment on attachment 143626 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=143626&action=review

> Source/WebKit/chromium/features.gypi:135
> +      'enable_css3_flexbox%': 1,

I would just hardcode ENABLE_CSS3_FLEXBOX=1 in the feature_defines variable.
Comment 3 Ojan Vafai 2012-05-23 13:44:33 PDT
Created attachment 143640 [details]
Patch
Comment 4 WebKit Review Bot 2012-05-23 16:09:16 PDT
Comment on attachment 143640 [details]
Patch

Rejecting attachment 143640 [details] from commit-queue.

New failing tests:
fast/dom/HTMLMeterElement/meter-styles.html
fast/css/display-no-show-hide.html
fast/dom/HTMLMeterElement/meter-styles-changing-pseudo.html
fast/dom/HTMLMeterElement/meter-writing-mode.html
fast/dom/HTMLMeterElement/meter-element-repaint-on-update-value.html
editing/deleting/delete-select-all-002.html
fast/css-grid-layout/grid-disabled-by-default.html
Full output: http://queues.webkit.org/results/12773359
Comment 5 WebKit Review Bot 2012-05-23 16:09:29 PDT
Created attachment 143669 [details]
Archive of layout-test-results from ec2-cq-01

The attached test failures were seen while running run-webkit-tests on the commit-queue.
Bot: ec2-cq-01  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 6 WebKit Review Bot 2012-05-23 16:43:28 PDT
Comment on attachment 143640 [details]
Patch

Attachment 143640 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12775372

New failing tests:
fast/dom/HTMLMeterElement/meter-styles.html
fast/css/display-no-show-hide.html
fast/dom/HTMLMeterElement/meter-styles-changing-pseudo.html
fast/dom/HTMLMeterElement/meter-writing-mode.html
fast/dom/HTMLMeterElement/meter-element-repaint-on-update-value.html
editing/deleting/delete-select-all-002.html
fast/css-grid-layout/grid-disabled-by-default.html
Comment 7 WebKit Review Bot 2012-05-23 16:43:32 PDT
Created attachment 143677 [details]
Archive of layout-test-results from ec2-cr-linux-02

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 8 Ojan Vafai 2012-05-23 16:51:15 PDT
Created attachment 143679 [details]
Patch for landing
Comment 9 WebKit Review Bot 2012-05-23 19:02:19 PDT
Comment on attachment 143679 [details]
Patch for landing

Clearing flags on attachment: 143679

Committed r118304: <http://trac.webkit.org/changeset/118304>
Comment 10 WebKit Review Bot 2012-05-23 19:02:24 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 Raphael Kubo da Costa (:rakuco) 2012-05-23 19:44:10 PDT
Committed the analog CMake change in <http://trac.webkit.org/changeset/118313>, please don't forget CMake in similar future patches.
Comment 12 Csaba Osztrogon√°c 2012-05-24 08:11:53 PDT
(In reply to comment #9)
> (From update of attachment 143679 [details])
> Clearing flags on attachment: 143679
> 
> Committed r118304: <http://trac.webkit.org/changeset/118304>

Qt fix after this change - http://trac.webkit.org/changeset/118332
Comment 13 Tony Chang 2012-05-24 10:17:45 PDT
*** Bug 87397 has been marked as a duplicate of this bug. ***
Comment 14 Philippe Normand 2012-05-24 20:14:31 PDT
(In reply to comment #9)
> (From update of attachment 143679 [details])
> Clearing flags on attachment: 143679
> 
> Committed r118304: <http://trac.webkit.org/changeset/118304>

GTK was forgotten as well... working on a patch...
Comment 15 Ojan Vafai 2012-05-24 23:50:21 PDT
Ugh. Sorry for all the breakages. I was just undoing the patch that removed the previously existing define. 

We have too many build systems. :(