Bug 85535

Summary: Remove dead code from build-webkit for working around old XCode dependency bug
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: New BugsAssignee: Eric Seidel (no email) <eric>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, dbates, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 85597    
Bug Blocks: 85456    
Attachments:
Description Flags
Patch none

Description Eric Seidel (no email) 2012-05-03 13:04:51 PDT
Remove dead code from build-webkit for working around old XCode dependency bug
Comment 1 Eric Seidel (no email) 2012-05-03 13:06:52 PDT
Created attachment 140076 [details]
Patch
Comment 2 Eric Seidel (no email) 2012-05-03 13:07:15 PDT
Comment on attachment 140076 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=140076&action=review

> Tools/Scripts/build-webkit:-426
> -$blobSupport = $blobSupport || $mediaStreamSupport;

I removed this line as I noticed it also was dead code. :)
Comment 3 Eric Seidel (no email) 2012-05-03 13:08:54 PDT
I noticed this because I was am looking at autogenerating the feature defaults in build-webkit.  There are basically no uses of the local variables the default options map to, and these were 2 uses.  This code is dead, so we should just kill it. :)
Comment 4 WebKit Review Bot 2012-05-03 14:06:35 PDT
Comment on attachment 140076 [details]
Patch

Clearing flags on attachment: 140076

Committed r116008: <http://trac.webkit.org/changeset/116008>
Comment 5 WebKit Review Bot 2012-05-03 14:06:41 PDT
All reviewed patches have been landed.  Closing bug.